No access to wan (via another router) from wlan

Raspberry pi, wlan is serving a new subnet lan is static ip on and a separate router provides the internet

had to add a static route on openwrt for and one on router for

(edit: only needed the return route on the router not one on openwrt for ping to work)

so on a device connected to wlan I can ping any device on and and dns lookup works but I cannot ping any device on internet such as

connected to openwrt via ssh on lan, openwrt can ping OK

I reckon it is missing a default rule for wlan on openwrt how do I set this up

ip route
default via dev br-lan dev br-lan scope link src dev br-wlan scope link src

sounds like your gateway needs to be told to NAT the non-local address range outbound.

sounds probable, I was expecting it to do that auto, but now you mention it maybe it only does it for stuff in the range and the packets from openwrt to the netgear are in range

not sure if can do that on a wnr2200 on stock firmware with the required precision, only on wan setup is a nat filtering option, secured or open

maybe need to rethink the topology and just hand out a reserved range in the network to the openwrt wlan

unless it's like the double nat thing is the solution, masquerade on the openwrt router to the lan?

maybe I'll stick a better linux firewall router distro on the link to isp supplied router in modem mode..... then go all in and upgrade wmr2200 to openwrt...