Newifi D2 (Newifi3) - 19.07.8 can access internet but not 21.02.1

Hi flygarn12,

Those 10 and 20 are just joke / fun of LINE numbers on BASIC programming and can be ignored.

Sorry for the confusion.

And 20.02.0 I guess is a typo also since we have no 20.02?

But the usual in this forum is when people upgrade from 19.07 to 21.02 and get DSA (either full DSA or “semi DSA” in combo with swconf depending on device) and get some non working setup from swconf era?

Hi flygarn12,

Yes, by 20.02 I meant 20.02.x

From my experience of Newifi D2, I can only flash 20.02.x firmware by
"Not keeping setting" and "Force upgrade"

and finally as mentioned my router A can work out of the box with default 20.02.0 configuration.
While my router B cannot which the OUTLOOK both routers looks the same and they both work properly with 18.xx and 19.xx firmware before.

I am not joking, we really have no version called 20.02 at all, no matter which service release you put in “x”.

1 Like

Yes of course.
What I meant is I tried both 20.02.0 and 20.02.1 and no luck on my router B.

Of course not. Those versions don't exist. Maybe you mean 21.02.0 and 21.02.1?

indeed, I was out of my mind,
even my subject wrote 21.02.

Yes, I meant 21.02.0 and 21.02.1...

Let me find time to correct the posts.

Thanks @psherman

Now I know what the real problem might be.

The issue is caused by clicking and refreshing right after package upgrade / install.
I tried fixing the problem router and found that at some time there was a warning about JSON and something about line 1 something...

It seems I do not encounter these if I perform any opkg actions in ssh or CLI.
It would only happen in luci.

Are you upgrading packages?

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.


Yes, you are the second person to tell me that.

I also have concerns with someone recommending an "auto recursive upgrade and reboot" cron job before when working with OpenWRT.

So, it ain't broke then don't fix it, huh.

Precisely. In some cases, upgrading packages may break things. Other times it is totally fine. But the problem is that it can be unpredictable and it increases the potential variables that are in play when something doesn't work. There are also other issues like the potential for things to fail badly -- especially if the device runs out of flash memory space mid-package-upgrade process.

So the root cause of my issue that 21.02.0 or 21.02.1 does not work on a certain hardware is because of "package upgrade" :joy:

Thanks for everyone who paid effort and time to work with me.

Now I got router A and B flash to 21.02.0 and 21.02.1 and working properly without much configuration change.

Kinda wish we had known that you were not using a true default config of those versions. Yes, package upgrades can cause unexpected issues and it is really hard for others to reproduce, especially if we don’t know what you have done.

But glad you’re running now.

Not really, there IS a point where I just flashed the "faulty" router with 21.02.0 and it cannot even ping from WAN side or access Internet from LAN side with router itself or DHCP clients.

The issue start to have some hints of success when I flash my "other" router from 18.0x to 19.07.8 to 21.02.0.

Sure... but after you had a running 21.02.1 installation, it seems you upgraded some packages and then things didn't work as expected anymore, correct?

I think that upgrade in LUCI is easier to encounter issue because one might click some link in LUCI and actually something is still in progress in the background..

If I do all the upgrade in ssh or CLI it seems no issue because I must wait for the command prompt re-appear before I can do the next action.

Detail: ( I keep ping to the WAN port IP during the following action and no issue found )

  1. flash firmware
  2. update software list
  3. (totally optional maybe) upgrade package in CLI / SSH
  4. remove / install package needed / wanted
  5. Config software in LUCI as liked

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Look this:


Well, glad that both of my router A and B (Newifi D2) has different MAC address.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.