[Newbie question] Wireless Management via LuCI - did I miss something?

Hi all, thanks for providing this awesome firmware and support. :slight_smile:
Just have to ask something perhaps rather obvious, though I wasn’t able to figure it out: Is it possible to access the configuration interface through Wi-Fi? I installed OpenWRT on a TL-WA901ND so far and couldn’t figure out what to configure - but since I also consider installing it on a RE305, I’d be rather glad if I could manage it at least wireless. :smiley:

Sorry if that’s been answered already, I wasn’t able to find anything on it. Hope to get pointed in the right direction then. :slight_smile:

Kind regards, Bobby

After installing OpenWrt, wifi defaults to being off - until you configure- and enable it from a wired connection.

2 Likes

Thanks, got the Wi-Fi repeater part working flawlessly - I just wasn’t able to figure out how to access the LuCI interface without having to hook something up by wire. :smiley:
Edit: Just to clarify, the TL-WA901ND is configured as a Wi-Fi repeater. It’s up and running but when trying to access the LuCI web interface via the IP configured on it’s wireless interface, all requests will time out. Wired configuration works without a hitch though. Is this device-specific, or may I just need to configure some options I overlooked before?

I set up a temporary (extra) SSID for rescue purpose on my RE200 for LuCI access via wifi :

root@OpenWrt:/etc/config# cat /etc/rc.local
# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

# Enable rescue wifi network after N seconds as per below
sleep 60
uci set wireless.default_radio0.disabled=0
wifi

sleep 600
# Disable rescue wifi network after N seconds as per above
# User needs to log in, and kill rc.local script in memory
uci set wireless.default_radio0.disabled=1
wifi

exit 0

/etc/config/wireless snippet:

...
config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid <redacted>
        option encryption 'psk2'
        option key <redacted>
        option network 'WLAN'
...

/etc/config/network snippet :

...
config interface 'WLAN'
        option proto 'static'
        option device 'wlan0'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
...

/etc/config/dhcp snippet (default settings)

...
config dhcp 'WLAN'
        option interface 'WLAN'
        option start '100'
        option limit '150'
        option leasetime '12h'
        list ra_flags 'none'
...