Newbie Q: Linksys WRT1900ACS and E3372 - offline setup?

To preface, I am a complete newbie to OpenWRT and my technical knowledge is fairly low. I have no broadband/WAN internet at home because there is currently no space in the fibre cabinet so I'm trying to set up a temporary solution using my router and 4G stick. I have a Linksys WRT1900ACS and a Huwawei E3372 4G USB dongle which I can at least get internet on my computer with, but I need a wifi network.

I have managed to install OpenWrt 19.07.7 (r11306-c4a6851c72) onto the 1900ACS and I can access the LuCI web interface by connecting an ethernet cable to my MacBook Pro but I can't install the drivers/packages needed to allow the Linksys to use the E3372 as a WAN interface as there is no internet for the router to access OPKG.

I've searched through the Forums and the Wiki and found a few articles. One option was to download the packages to my MacBook and then install them manually, so I checked for the right version and architecture - according to this it should be arm_cortex-a9_vfpv3 so I then found the right section in the repository here and tried to find the right packages to download.

I've looked at lots of posts and articles (e.g. and they all suggest getting various kmod-usb pakages and usb-modeswitch, but I can't see those in the repository above.

The closest thing I could find was the CCID and modemanager packages, so I downloaded those and uploaded it using LuCI, but then I get an error:

Collected errors: * pkg_hash_fetch_best_installation_candidate: Packages for ccid found, but incompatible with the architectures configured * opkg_install_cmd: Cannot install package ccid.

The opkg install command failed with code 255.

So now I'm at a loss. I can't find the packages in the guides, I can't get OPKG to work on the router without internet and I can't get internet without getting the router to recognise and connect to my 4G dongle!

If it helps, here's the status page from LuCI:

|Hostname| OpenWrt|
|Model| Linksys WRT1900ACS|
|Architecture| ARMv7 Processor rev 1 (v7l)|
|Firmware Version| OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.044.30835-34e0d65|
|Kernel Version|4.14.221|

Any help would be appreciated

not a solution, but a workaround.

wirelessly share internet from your cell phone, connect the linksys to your phone over wifi as a wireless client.
nework->wireless->scan (button) -> join network. if prompted for zone, try WAN.

install packages required for E3372 support.

1 Like

@frollic - that has worked! Brilliant, thanks :grinning:

I couldn't see how to join a wifi network but that was really easy. It doesn't answer why the other method didn't work, but just installing the packages now and will see if that works to get the E3372 working... :crossed_fingers: