Newbie need help seting up OpenWrt


I’m totally new to openWRT, and I have a very limited understanding about networking.
I’m trying to make the change from dd-wrt to openWRT on my TP WR1043ND (V3).
I’ve installed openWRT on it and tried to set it for some hours, but could not figure how to do it. I just could not get it to pass the internet connection to it’s LAN plugs. I searched for a very long time for a tutorial that will show me what to do, but just could not find one that will suit my setup.

My set up is:
DHL Modem is D-link DSL-G225. In it I have a PPPoE with my isp login data.
It also has DNS set in it and the wifi is off.
I can write down the full setup steps I make in it.

From the D-link I have a cable going out from the LAN plugs into the WAN plug of the WR1043ND.
The WR1043ND need to act as:

  1. Wire internet to desktops PC’s.
  2. Wifi service.
  3. NAS using a USB HDD (NTFS formatted).
    1. Wire connection to another router which is used for wifi service with the same SID as in step 2 (already changed it to openWRT using this process:
  4. Act as firewall.

I’m sure that there are many toutorials for this setup, but I probably don’t know the name of my configuration and so could not find the full explanation.
Could someone help me on how to set this openWRT machine so I could have the internet connection in its lan plugs?

For the NAS I found this:
is this the correct way?


i don't have this kind of ...., but login via web , and under interface wan, change DHCP for PPPoE, added the username and password. that is the first steep.
you can wait a replay from someone with the same situation as you.

@anon4457646 this is good enough explanation!
The modem already makes the login process to the ISP so why should I put it's user name and password in the openWRT router?
When I connect a PC to the modem LAN I get to the internet without the need for that ISP login.

I found a log of what i did In the dd-wrt:
-> basic:
connection type=Auto DHCP
local IP Addres=
subnet mask=
DHCP type=DHCP server + DHCP enable {this is the default}

How can I do this in openWRT?

The default configuration should work out-of-the-box for your situation... except when both devices have their LAN networks configured on the 192.168.1.x segment. Just configure one of them to 192.168.0.x, and it should work fine.


They are probably both at 192.168.1 (I'm, not near them now to test)
So how do I change the openWRT router to 192.168.0.x ? is it done by changing it's IP in the LAN or WLAN tab?

interface lan


I managed to set the internet connection

For the next newbie:

connect with wire (in yellow plug). ipconfig, connect  
network -> interface -> lan -> edit
	IPv4 address=
	save & apply: ---> there a time limit now!!!
		YOU MUST connect to the new ip before a limited time, or it will revert back.
		open a new page on the before the save & apply and keep updating it.
		you can also look using ipconfig.
		disconnecting and reconnecting network cable to pc can also help
	connect to
	connect WAN plug to modem LAN an make sure the internet works!

Now I'm stuck with the NAS.
I'm using:

I've installed the the packages and the router detects my USB drive as /dev/sda1
I added a mount of it on /mnt/sda1 with auto filesystem and it set it as ntfs.
But in SSH, when I run ls -la /mnt/sda1/ I see no files. When I connect the drive to my PC I see the data

What could be the problem?