New official firmware wrt3200 acm

I followed the instructions here but the kmod installation failed.

Some time ago @eduperez through github, gave me suggestions for compiling the drivers. Now I am more practical than that and already I was able to. The problem you are experiencing may be that there was a kernel update in 19.07.1. The version I compiled I am sure is for 19.07.1 stock. The advice I can give you, if you really want to try the new firmware is to use the entire image you find at the same Google Drive link and flash the entire 19.07.1, which already contains the updated firmware (so you don't have to install anything else). Then through opkg you can install the packages you need. Maybe LuCI, which isn't already installed. While I am on master with already everything I need to work compiled inside. I have been using the new firmware for a long time now and highly recommend it.

I downloaded your firmware, installed, but it still shows the old driver:

root@OpenWrt:~# cat /sys/kernel/debug/ieee80211/phy0/mwlwifi/info

driver name: mwlwifi
chip type: 88W8964
hw version: 7
driver version:
firmware version: 0x0903020c
power table loaded from dts: no
firmware region code: 0x10
mac address: 24:f5:a2:2f:cb:ba
2g: disable
5g: enable
antenna: 4 4
irq number: 49
ap macid support: 0000ffff
sta macid support: 00010000
macid used: 00000000
radio: disable
iobase0: e0e80000
iobase1: e1100000
tx limit: 1024
rx limit: 16384

Indeed it is correct, yours like mine is the new firmware version. The date refers to the driver and not to the firmware.

1 Like

A side note:
sqm must not be enabled in your package selection?

If you want I can build it with sqm and if you want with luci-app-sqm, but can't you install by opkg?

I tried that after installing luci,nano, adblock,etc. which went fine. SQM was the only error so far.

How are the official images able to install any package? I’d like to be able to include the newest drivers and have that capability as well with other custom options.

I agree and it should be so. sqm is a kernel module and what I compiled is exactly at the 19.07.1 tag, but for a reason that I ignore it is not compatible with the packages in the corresponding repository. If anyone has suggestions let me know. Basically you will have problems with any kernel support packages.

After some extensive research, I found this How to compile openwrt and still use the official repository

1 Like

I have rebuilt the drivers, including the latest commits and the latest official (wireless) firmware, to be used over the 19.07.1 release:

I haven't had time to test these myself, so please handle with care.


I'm happy to test them. How does one install these properly? Git clone? wget? opkg?

You basically have to download the packages to the router ("wget" or "curl") will do, update your package list, and install the new packages ("opkg update && opkg install *.ipk").

Roger that. I'll get right on it.

Interesting. I am going to read it.

1 Like

It's an interesting read (thanks @mindwolf), it explains pretty much the same procedure I follow to create updated kmod packages for the stable releases.

The part I left out and created the problem was not copying the config.seed file

No Problem! That’s the gist I was getting after reading that article. Also why does the 3200acm have 8 queues with a dual core processor? Seems a bit excessive? Can someone explain the logic?

My end goal is have 1ms he timing, install from official repos, with the ability to update the WiFi drivers.
Please if you can try the image or simply the module with the driver. I rebuilt everything following what described in the excellent page you shared. I checked the kernel vermagic in the .manifest file of the official page of 19.07.1 with that of the build I made. It matches perfectly. Then you can use opkg and the repositories made available by the project without any incompatibility errors.

I'll try it out tomorrow, today has been exhausting with Mardi Gras! Thanks for your efforts in advance.