New Device Ubiquiti Bullet AC

Ubiquiti has a new IP67 device called Bullet AC (See here https://www.ui.com/airmax/bullet-ac/)
Since now we used the older model Bullet M2 with OpenWRT but it is no longer available. Ist there already a Release available for the Bullet AC or a similar one which fits to this chipset that I could try?

Thank you in advance,
Fabian

Hi,

I have this working, and was actually just logging in to see if there was any official release support yet?

I bought the Bullet AC IP67 (black) because I needed DUAL band. My application is mobile/vehicular and sometimes I need 2.4Ghz, and other times 5Ghz. Was surprised to see nobody else had tackled this yet.

What you will find is that in general, the Ubiquiti AC (AirMax) lineup all will support OpenWRT.
There are various hardware boards (i.e. WA vs. 2WA etc...) in these devices.
There was a lot of support for WA, but nothing supported for 2WA.

The Bullet AC IP67 (black color) uses the 2WA board - but in research I found this 2WA board uses similar hardware (qualcomm atheros chipsets) to the Nanostation, Nanobeam<?>, and Bullet M.

Through trial and error I was eventually able to hack together an OpenWRT version running on Bullet AC IP67.

What we need is for an OpenWRT Dev to package that recipe into an officially supported release so the drivers are right and most importantly to me... the hardware name reflected properly on the status page haha.

If you can help figure out who we need to help package this up, I am happy to DM or create a post supporting the matter.

1 Like

Congratulations!

See https://openwrt.org/submitting-patches for how to submit a patch to get this device officially supported by OpenWrt.

Thanks Thomas!
This was exactly what I was looking for but didn't know terms to search for.

I'm still limited on time but will try to see this through this week.
Here's an update for our OP friend to get him going in the meantime.

Hi, So I was motivated to play with this again last night.

I am now using AR9342 w/ ath10k-ct drivers.

Does anyone know?
Is there an equivalent of LSPCI from within OpenWRT where I could just lookup or reverse engineer the hardware ids so we can conclusively determine which drivers are necessary? I looked on FCC but only garbage.

I still don't think I have the right drivers, and OpenWRT reports:

Radio 1: Generic MAC802.11BGNAC
AND
Radio 2: Generic 802.11BGN (2.4Ghz mgmt radio is also working!!)

Signal Strenth: -74/-104. (9dbi omni, 23dbi OWRT power setting?)
I'm using client mode, on a moving/floating boat, about 300 yards away from the indoor AP source, through a crowded marina full of sailboat masts. This is stable enough to stream 1080p video and push the full 20-30Mbps client billing limit.

Here are some firmwares that will work for you out of the box
CAVEAT They all have their issues and report "Generic WLAN".

1.) Nanostation AC Loco (Works, but I don't think the WLAN drivers are right, lots of disconnects).
2.) Nanostation AC - DOES NOT WORK. (at least I couldn't get it to?)
3.) Nanobeam 5AC Gen2 (Works, this is where I got put on to the ath10k-ct drivers - still don't think
drivers are right).
4.) Bullet M - Def will not work.

Also OP

Could you please RENAME this thread to include [2WA Board Support].
So far there is NO OpenWRT support for 2WA boards so this would help lots of other people using those other devices as well.

(like the NanoBeam 2AC etc...)

Thanks for your replies! That's great you managed this to work!
I will try the Nanostation 5AC Gen2 on the device soon.
Please let us know when you have an official release.

Any update on this?

1 Like

I submitted a patch to support the Bullet AC several days ago. I have not actually tested the instructions for installing via patching fwupdate.real. For my one device, I used a serial console and tftpboot'd an initramfs image and flashed from there (that is, using the "Flashing from serial console" instructions).

1 Like

New version of the patch, fixed so that the "Flashing through factory firmware" instructions actually work:

https://patchwork.ozlabs.org/project/openwrt/patch/874kkm3th8.fsf@husum.ptp/

1 Like

Nice work russell!

I'm sure this will help a lot of people out. Hopefully this patch will be accepted soon.

Thank you for your work Russell.
I am unable to get the secondary (management) radio running with this patch. It gets recognised as another radio in luci, but whan I try to enable it, it freezes the whole device, and I need to factory reset to resume control. The secondary radio runs perfectly in AirOS. Is this the same result others get with this patch, or do both radios "just work"?

I saw that too. easy solution is leave the second radio off. patches welcome.

It's a bit beyond my level unfortunately. I have been trying to access the management radio for a while now, to make a wifi hotspot repeater. The secondary radio would only need to reach a couple of metres, and the main radio has plenty of power to reach a long distance. I'm out of ideas though, so if anyone has been able to do this, I would really love to hear how.

Why not have a second interface on the same radio in AP mode?

My patch (v3) was merged today.

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=591a4c9ed3a3e3d9b0a2d1dd856c1df87892b877

You said you connected to your unit via serial. I opened mine up and found two spots that could be for the serial header. Did you use J6 (closer to the ethernet connector) or J10 (closer to the middle of the board)?

Google Photos

If it's like the other AC units, the other header goes to the 5 GHz chip and may output a few messages but not anything useful for development.

Thanks. When I tried enabling the 2nd radio the unit immediately stopped working. I'm hoping I'll be able to bring it back to life via the serial header.