New Build for Xiaomi Router 3 / R3 / MIR3 - OpenWrt v21.02.5 / Snapshot

Xiaomi R3, is not in the official OpenWrt support list, and discontinued for years. But in second hand market, it's very lower cost, normally lower than us$10. And it's still better than some new low-end routers.

Check: https://openwrt.org/toh/xiaomi/mir3 for details, some hot points: 128MB Nand flash rom / USB(2.0) port / 2.4G+5G wifi / 100Mb eth......

Thanks for github repo maker XFY9326: Xiaomi-R3-OpenWrt-Stable

How to use my unofficial build: (if your device already installed openwrt, simple upgrade it using sysupgrade.bin file)

  1. get the SSH root access, I use OpenWRTInvasion method, you could refer to any others.
  2. setup uboot env settings to enable serial port:
nvram set uart_en=1
nvram set flag_last_success=1
nvram set boot_wait=on
nvram commit
nvram show
(confirm all)
reboot
  1. get the SSH root access again.
  2. mtd write the kernel1.bin and rootfs0.bin by SSH or USB (/extdisks/sda1). same as R3 / R3G nand flash programming method.
  3. reboot and open 192.168.1.1 as normal openwrt.

Some of installed features in my build: Argon theme / ACL / USB file sharing / Simple Adblock / DDNS.
Here is my build link: xiaomi-r3-21025-20221021.zip
xiaomi-r3-snapshot-20221028.zip

1 Like

ive flashed it quick yesterday but didnt get ssh or luci. ive read standard address is 192.168.15.1 or at least i tried manually configuring both 1.1 and 15.1 and portscan showed it on 15.1. coming from xwrt with sysupgrade and resetting the settings. portscan confirmed it was on the right address. probably something i did wrong i didnt bother spending time to fix it i will when needed. i tried reset and didnt fix the issue. just asking in case ill hook it up to fix it again to make matters easier. i guess id have to connect uart right. and something off topic, i was wondering if the kernelname could be spoofed to miwifi mini. at least through userspace or something. if not it could through the kernel config. that name must be based on commits. so that openwrt repositories can be used for kmods. i havent checked your build yet since the above. thanks for supporting this device. i didnt bother reading too much just flashed the sysupgrade fast as ive said and did something wrong dont want to give the wrong impression. i also have this browser issue with chromium now and then so i think that might have been the case that it doesnt pickup on luci. if i had resetted settings its logical ssh would be off. i think thats why.

try to do a factory reset, long-press the reset button.

1 Like

at the moment i wrote this i was clueless and wasnt in the mood for fixing. right now i realize im 100% sure it was the browsers fault which sometimes doesnt work with luci. chrome on linux is buggy. firefox usually works. btw if youre up for it check this CeroWrt II - would anyone care? - #266 by thanas

understand, the browser always kept something in cache for speeding. I have to clean it up manually, especially chrome.

1 Like