Network problem via SSH

Hi,
I have a problem the internet is not working via SSH and luci but is working in my computer and other device when I try opkg update is show me this error

opkg_download: Check your network settings and connectivity.

My router is tp-link wa801nd v5 and I use OpenWrt SNAPSHOT r11243-07b5c59232

/ect/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd02:c838:2286::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1 eth0'
	option proto 'static'
	option ipaddr '192.168.1.202'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '8.8.8.8'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config interface 'wan'
	option ifname 'wlan0'
	option proto 'dhcp'

/etc/config/dhcp


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

Thanks

It looks like you are using another wifi network as your WAN and obtaining a DHCP address. In that case do not set a gateway or dns under LAN (if you did need to manually configure those, it would go under WAN).

Also when NATting, the LAN and WAN IP ranges must be different.

1 Like

yes I use before other wifi network to install luci but i remove it now I need just to get the internet from the port not from wifi