Network Configuration For Unifi 6 Lite AP

I have been using a Linksys WRT3200ACM with OpenWRT for a WAP. This sat behind a Netgate 3100SG in a double NAT configuration. With my most recent network upgrade, however, I wanted to have a Wifi 6 capable wireless AP while still keeping my PFSense box as my main routing device and getting rid of the double NAT configuration. I did some research, and decided on the Unifi 6 Lite from Ubiquiti. I've successfully flashed OpenWRT to the device, as it was fairly quick and easy for a Linux user like me. I will make some contributions to the device page to make it better and easier to follow - especially for less experienced people. That being said, however, I mistakenly installed the snapshot version of OpenWRT, so I don't have LUCI. Also the current device page is rather hard to find: https://openwrt.org/toh/ubiquiti/unifi_6_lite, as the old device page is a dead link that shows up in search results more readily. It would be nice if it were more clear what versions of the OpenWRT firmware can be installed on this device when installing it for the first time too.

Anyway, my mistakes aside, the thing I need help with is that I do not have access to the Wide Area Network on this device so I cannot perform software upgrades with opkg and install LUCI or even SFTP. I don't know what my other options are; so I was hoping someone could help me get my WAN working in OpenWRT. Here is the current /etc/config/network file:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdf3:705f:c47a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.57.2'
	option netmask '255.255.255.0'
	option ip6assign '60'

It is pretty much the default file that existed with the device. I only changed the IP Address to match my LAN subnet so that it wouldn't conflict with my PFSense box. Here, also, is the output of ip a:

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
    link/ether d0:21:f9:b6:75:44 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d221:f9ff:feb6:7544/64 scope link 
       valid_lft forever preferred_lft forever
3: lan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether d0:21:f9:b6:75:44 brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether d0:21:f9:b6:75:44 brd ff:ff:ff:ff:ff:ff
5: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether d2:21:f9:b6:75:45 brd ff:ff:ff:ff:ff:ff
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether d0:21:f9:b6:75:44 brd ff:ff:ff:ff:ff:ff
    inet 192.168.57.2/24 brd 192.168.57.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fdf3:705f:c47a::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::d221:f9ff:feb6:7544/64 scope link 
       valid_lft forever preferred_lft forever

Usually it's what I turn to to find networking issues, but this time it didn't help me. Also, my ISP is Google Fiber, and it doesn't support IPv6, so I tried to disable IPv6; but I was unsuccessful. Additionally, I've attempted to disable DHCP, I end up losing SSH access and have to reset it. I must be doing something wrong here. It could also be a problem with my PFSense configuration now that I think about it. I have that set up to assign the Unifi 6 Lite's MAC address to 192.168.57.2 permanently though. This device only has one port, so that's been my biggest problem when trying to configure it. I've messed with it for 3 days, but I got work to do; so any help would be appreciated.

Sounds to me you want dumb AP - https://openwrt.org/docs/guide-user/network/wifi/dumbap

For name resolution to work, you can temp populate /etc/resolv.conf

If there's no Luci, you probably flashed a snapshot image by mistake, stable releases come with the web UI.

Which search and which old devicepage are we talking about?

Yeah I know. This isn't the problem I am trying to solve at the moment.

Yeah I did. You probably missed that in my wall 'o text xD.

WDYM by this? Is name resolution why I cannot access the WAN?

DuckDuckGo and https://openwrt.org/toh/ubiquiti/unifi6lite

If you set up as an AP, there's no WAN, and upstream DNS, unless you skipped the static IP, and configured it as DHCP client.

Can't you access "wan" (= internet access?), or is the name resolution failing? Two different things.

With a static IP you manually have to provide a DNS, which can be done in the settings, or just by editing the resolv.conf. The latter doesn't however survive a reboot, but isn't really an issue for an AP.

Might need to provide a gw too.

Thanks, I have added a redirect now.

1 Like

How can I configure it as a DHCP client, and do you know where the wiki page to editing resolv.conf is?

Go to the LAN interface, and change client type from static to dhcp client.

If you do this, the resolv.conf isn't needed.

Do one of them, not both.

Resolv can be edited using vi, or winscp, from a windows client.

Well I can set it as a DHCP client, but how can I do that from UCI? I don't have LUCI remember.

Wait I think I found the answer. LMK if this is wrong: https://openwrt.org/docs/guide-user/network/openwrt_as_clientdevice

Yep, correct.

Good find.

1 Like


It worked. Thanks. Also, because my PFSense box is configured to assign my OpenWRT device the same IP address (using its MAC address); this solution was the best for me because it is easy.

Just for the future, it would have been easier (and better to read) if you had copied-and-pasted the terminal output into a codebox </>.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.