Network config review: KPN Fiber

Hi, Can someone review my network config that i edited for use KNP Fiber. (as its not working)

error msg: unknown error USER REQUEST)

I used this link to start: https://openwrt.org/docs/guide-user/network/wan/isp-configurations#kpn_ftth

This is the details provided by the ISP: (in dutch, let me know if translation is needed)

Technische details Internet
• PPPoE via VLAN 6 (802.1q).
• PPPoE authenticatie PAP met een gebruikersnaam en wachtwoord (bijv. internet / internet).
• Maximale pakket grote (mtu) 1500 bytes (rfc4638)
• IPv4 adres + DNS servers via PPPoE verkrijgen
• IPv6 adresreeks + DNS servers (IPv6) via DHCPv6-PD verzoek (in PPPoE). Een adres gebruiken uit reeks voor router.

I reboot both router and Fiber convertor (ONT) after each edit.

I think the issue might be in the vlan part?

The fiber install boy said the line should work. (got 3 green lights: Connected / Power/ Data)

the config i build:

#edited by Luci and me
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:2479:fdfe::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        option delegate '0'

config device
        option name 'eth0.2'
        option macaddr '64:66:b3:f4:18:69'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option type '8021q'
        option vid '6'
        option username 'internet'
        option password 'internet'
        option ipv6 'auto'
        option mtu '1500'
        option metric '1'

config interface 'wan6'
        option device 'pppoe-wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '2001:4860:4860::8888'
        list dns '2001:4860:4860::8844'
        option metric '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'


As reference: this is the config as currently in use and working with the cable modem (ziggo)

#Org (Ziggo Cable)
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:2479:fdfe::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        option delegate '0'

config device
        option name 'eth0.2'
        option macaddr '64:66:b3:f4:18:69'
        option ipv6 '0'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'
        option delegate '0'
        option force_link '1'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'        

I would be very grateful if someone takes the time for a quick scan as im just not knowledgeable enough to fix it.

You need to approach local forums, namely review MTU

tnx for the responds, I will do that. although bad MTU should cause bad performance, not total connection failure. But as im not an expert, might be proven wrong :slight_smile:

MTU blackhole resolution should be like 30s freeze at start of connection but working in the end.

I got KPN too, the config seem to look fine.

Though ive been told username and password can be anything, though in past experiences it not always help (i think due to the temporary hold on the previous mac from the experiabox), there is a cooldown.

I often use this although it shouldn't mather:

username: 00-00-00-00-00@internet
password: ppp

Where the 00 is your mac address.

The VLAN is not set up properly. According to the directions, this ISP requires the pppoe packets to be tagged VLAN 6 when they reach the ONT.

In the wan section, change device from eth0.2 to to eth0.6. Change the switch-vlan section to be this (the VLAN ID number is changed from 2 to 6 and port 1, the physical WAN port, is set to tagged by adding a 't').

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1t'
        option vid '6'
1 Like