Netgear WNR2200, revert back to OEM stock firmware

Hello, Everybody.

Just want to have a fallback option. I have found documentation on my device (WNR2200), but it is somewhat vague. Could someone please elaborate on "Flashing from OpenWrt" section in more details.

  • Do this instructions work for flashing back to the original firmware (WNR2200-V1.0.1.102.img)? I most probably have the Russian edition of the device.
  • Why can't I just flash from the OpenWrt GUI?
  • What is the strange router rebooting procedure for?
  • Will tftp from the tftp-hpa Ubuntu package serve the purpose?
  • How do I go about changing my laptop IP address to static I tried to do it through NM GUI, but OpenWrt still have active DHCP lease for the remaining. I am running Ubuntu 18.04 from the liveUSB on my laptop.
  • Are there other, preferably more safe, ways to flash back to OEM?

Your help will be much appreciated.

I have followed this guide, but to no avail. Here is the output of "ip a" and "tftp" commands:

2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 68:b5:99:5d:62:6b brd ff:ff:ff:ff:ff:ff
    inet brd scope global noprefixroute enp3s0
       valid_lft forever preferred_lft forever

tftp -v -m binary -c put WNR2200-V1.0.1.102.img
mode set to octet
Connected to (, port 69
putting WNR2200-V1.0.1.102.img to [octet]
Transfer timed out.

I don't think router even entered tftp recovery mode, judging on the Power LED's behavior.
Any ideas?

The section in the wiki is pretty straightforward. Most of Netgear routers have a rather similar TFTP recovery flash procedure.
(Similar advice for R7800: Netgear R7800 exploration (IPQ8065, QCA9984) )

Just for triggering the recovery flash mode during the early boot process:

Sounds like you have not been able to make the device to enter the TFTP recovery flash mode. The advice in wiki for WNR2200 sounds a bit peculiar, as usually you need to release the reset button while the power LED still blinks.

You may need help from somebody who actually has WNR2200 to figure out the exact moment.

That's the problem. LED does not blink amber no matter what. It only blinked green while I was holding the reset button without rebooting. I was pinging simultaneously, but output was just as usual.

Is it possible WNR2200 does not support tftp recovery mode?

Forget about an amber led. That is just for R7800.

But the wnr2200 wiki pretty clearly explained the tftp, do it likely is there.

I got lost when you talked about not rebooting. Tftp mode is triggered in early reboot process, so rebooting is needed.

Found an old article about your device

How do I find out if device entered tftp mode, assuming LED indicators don't show it?

I don't think it's valid information in there, I tried it though, no luck.
Found this thread on the Russian Forum. They say the only ways of entering recovery are either soldering or connecting through the internal pins of the device.
I guess I am stuck with OpenWrt for now.

WNR2200 16M (WNR2200-100RUS) does not support tftp recovery. You can try nmrpflash, use U-Boot console via UART or just flash the factory firmware from OpenWRT, if you still can get root access. Remember, that valid firmware should start with 2200 (0x32323030) in first 4 bytes. Firmware files provided by Netgear have additional 128 byte header, which you need to strip, before you can flash it in the rom.
Check the boot logs after you flash the firmware to make sure ART offset is correct (should be 0x0ff0000-0x1000000 for 16M flash), you can also check hexdump -C /dev/mtdXro to see make sure it contains your wps pin and serial number at correct offset (0x0C or 12 decimal), after two MAC addresses, each taking 6 bytes.