Netgear WNDR3700v4 not booting anymore after upgrading to 21.02.01


Ich flashed my Netgear WNDR3700 v4 (Atheros AR9344; ar71xx-ath79; nand) from Rel. 19.07.0 to Rel. 21.02.1 (latest version according hardware table).

First there was a warning message - but seemed to be just a typo:

I forced the upgrade - now it doesn't boot anymore... :sob:
(status LED first orange - then blinking green all the time...)

All other previous updates worked fine.

Any hints welcome!!


It is a Netgear router, so it likely has the same TFTP recovery flash routine in the bootloader as e.g. WNDR3700v1 and R7800 etc. You should be able to recover the router by flashing a new "factory" image with that TFTP tool.

(WNDR3700 v4 is different than those routers I mentioned, but Netgear has been pretty consistent with the bootloader)

See advice e.g. in

Many posts in the forum about this router. Just backup your config and do tftp flashing and it'll be alright.

Reverse to OEM firmware using nmrpflash, than flash openwrt 21.02 factory. Do not upgrade from 19.07, the partition layout has changed. Once done this router works fine under 21.02.
Yes many answers to this issue have been done weeks ago.

Dear all,

Thanks a lot for your advices!
TFTP recovery with a 19.07 factory image worked.

Is only the upgrade from 19.07.1 an issue or from any 19.07.x to an any 20.02.x an issue?

Thx & BR!

It's about upgrading from 19.07.x to anything above, see: WNDR4300: upgrade from ar71xx to ath79 - #3 by pepe2k

Yes it's only upgrading from 19.07 that cause issue as the partitions layout has changed. Flash directly a 21.02 factory image with TFTP or from Netgear GUI. That works well. Once done, you can safely upgrade to newer releases. I have flashed a new build yesterday.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.