Netgear WAX220 support (almost complete)

I dont think so. I have two WAX220 and no devices have ever had conncectivity issues. Then again i have no Apple devices. Only speed issues with the uplink.

Yesterday I decided to flash again openwrt on my WAX220.
The last vendor firmware started to exhibit some nasty glitches with WMM with my yamaha AVR.
Well it seems stable, however there are an inconsistency between the AP and the router reported link rates.
ethtool on the router (ER-X) says 1gb full duplex
ethtool on the AP (WAX220) says 1gb unknown duplex (ERR 255).
iperf3 test is consistent with a 1gb full duplex speed.

Have you tried with snapshot to compare the behavior?

I just flashed mine to latest snapshot but not yet tested, can you show me how to reproduce the problem?

It could not be reproducible, because It could be hardware dependant:

That's why I and others suggested a note in the wiki of nwa50ax pro and wax220...

OK I looked into that Github comment, so what they mean is, WAX220 might have more than 1 type of LAN PHY and Realtek PHY is known to have problem? I might take a look of mine tonight.

Nope, it says that there are various revisions of realtek phy and some of them are problematic (the oldest one).

I just tested and my WAX220 has the same problem as well :frowning:

You could try buying a 2.5gb switch...
Otherwise you have to revert to the vendor firmware, which has a severe bug with WMM and probably with multicast to unicast.

Is it possible to force duplex? And I just tested with 100M and it's even worse, unable to connect at all.

You can using ethtool and running

ethtool -s eth0 speed 1000 duplex full autoneg on but the results show that it doesn't exactly fix the issue. See my post above about the speed tests when I tried it.

If you are affected you can only buy a 2.5gb switch or revert to stock firmware or wait for a fix by openwrt developers