Netgear WAC104 can't power cycle

I was able to install both the snapshot and the RC for the WAC104 using the factory image and nmrpflash. After the flash I power cycle and everything seems to be fine. Luci web interface works, lan works, wireless works. Only problem is if the power goes down the router doesn't seem to boot anymore. From the LEDs it looks like it starts booting gets about 7-10 seconds in and resets. This is same behavior as when i tried to install the image with the factory method. I poked around the logs and didn't see anything obvious.

Any ideas?

Could be a partition related issue. I don't think that using nmrpflahs to install a factory image is a recommended behavior (thus I may confess I did once). Use nmrpflash to restore stock firmware. Reboot a couple of times to be sure that it works correctly. Than use factory image within the stock GUI.

well, my temporary solution of not power cycling the device and leaving it connected to a UPS finally failed.

I tried flashing back to the factory, then using the netgear UI to upload the factory image with no success. Three different images fail in the same way. I also tried doing an upgrade with luci and sysupgrade after the factory image was running and both failed the next boot.

I was able to get a slightly different result when i tried to write the factory image manually to the MTD kernel and ubi partitions but I'm not sure I did that correctly as the lan LED stayed flashing but the power LED turned off and the device was unresponsive.

I have been experiencing the same thing. The odd thing is, I have two WAC104s and only one of them does this. The other one has no issue when power is removed. Also... it isn't immediate. If I flash the thing with OpenWRT, I then need to unplug it and move it back to its normal spot in the house. When I reconnect it, it comes back up fine. It seems more like it needs to be up for a certain period of time before it goes into that odd "stuck" mode where the boot never completes. Makes me wonder if something like logging is filling something up in the file system preventing the system from booting the next time around.

What's worked for me the previous two times this has happened is using the nmrpflash tool to push the factory image to it, then installing OpenWRT from the image that I keep stored locally. The is currently this one: openwrt-ramips-mt7621-netgear_wac104-squashfs-factory.img After that, I have to go through the set up, install luci, etc... It's kind of a pain, but so far I've not found anything online that explains what might be happening. I know when it gets into this mode because the only lights on are the power LED and the one network jack (usually port 1) that has the network cable in it.

I keep planning to save my config to the network so I can recover that more easily, but I still need to install luci, so I don't know if it would save me much time. I have tried some of the recovery options with hitting the reset button at the right time during the boot, etc... but none of that does anything. At this point, since it only happens on one of my two Netgear WAC104s, I'm thinking there is a specific build of these that might be slightly incompatible with OpenWRT, or have some hardware limitation causing the issue.