Netgear stora MS-2000 + OpenWrt 18.06.4

Hi @danitool , just wondering, is this helpful in finishing the WIP for the Stora?

Hello @eldaveo007! Answer here 21.02 snapshot error opkg update

I use snapshot repository 21.02 in my images.

@Nevskiy sorry - might be confusing - so I do this:

Ok. I changed distfeeds.conf

src/gz openwrt_core
src/gz openwrt_base
src/gz openwrt_freifunk
src/gz openwrt_luci
src/gz openwrt_packages
src/gz openwrt_routing
src/gz openwrt_telephony

Hi @eldaveo007, until official support is reached, the device will remain WiP. BTW the wiki page can be moved from inbox to the ToH.

Done, page moved to

1 Like

@Nevskiy Did you have any trouble getting Samba working correctly? Its 99% working now for me, but I have 1 problem.

Remote computers can not copy / download off the SAMBA shares. They can browse and write files, but not copy off? It must be something simple, but I can't seem to find what is interfering?

@eldaveo007 Hello!

Sorry, my SAMBA work is perfect. May be you have problem with premission, or not correctly smb.conf?

I have figured it out (i think) the samba default for create mask was 0666 for the shares which didn't seem to work. I changed it to 0777 and that seemed to fix it. I tried configuring users but I wasn't able to get it to work, as in, i set it up and samba appeared to accept it, but neither Windows or Mac were able to log in with the defined credentials.


If will help it. My smb.conf

        netbios name = OpenWrt
        interfaces = br-lan
        server string = Samba on OpenWRT
        unix charset = UTF-8
        workgroup = HOME
        min protocol = SMB2

        ## This global parameter allows the Samba admin to limit what interfaces on a machine will serve SMB requests.
        bind interfaces only = yes

        ## time for inactive connections to-be closed in minutes
        deadtime = 15

        ## disable core dumps
        enable core files = no

        ## set security (auto, user, domain, ads)
        security = user

        ## This parameter controls whether a remote client is allowed or required to use SMB encryption.
        ## It has different effects depending on whether the connection uses SMB1 or SMB2 and newer:
    ## If the connection uses SMB1, then this option controls the use of a Samba-specific extension to the SMB protocol introduced in Samba 3.2 that makes use of the Unix extensions.
        ## If the connection uses SMB2 or newer, then this option controls the use of the SMB-level encryption that is supported in SMB version 3.0 and above and available in Windows 8 and newer.
        ## (default/auto,desired,required,off)
        #smb encrypt = default

        ## set invalid users
        invalid users = root

        ## map unknow users to guest
        map to guest = Bad User

        ## allow client access to accounts that have null passwords.
        null passwords = yes

        ## The old plaintext passdb backend. Some Samba features will not work if this passdb backend is used. (NOTE: enabled for size reasons)
        ## (tdbsam,smbpasswd,ldapsam)
        passdb backend = smbpasswd

        ## Set location of smbpasswd ('smbd -b' will show default compiled location)
        smb passwd file = /etc/samba/smbpasswd

        ## LAN (IPTOS_LOWDELAY TCP_NODELAY) WAN (IPTOS_THROUGHPUT) WiFi (SO_KEEPALIVE) try&error for buffer sizes (SO_RCVBUF=65536 SO_SNDBUF=65536)
        socket options = IPTOS_LOWDELAY TCP_NODELAY

        ## If this integer parameter is set to a non-zero value, Samba will read from files asynchronously when the request size is bigger than this value.
        ## Note that it happens only for non-chained and non-chaining reads and when not using write cache.
        ## The only reasonable values for this parameter are 0 (no async I/O) and 1 (always do async I/O).
        ## (1/0)
        #aio read size = 0
        #aio write size = 0

        ## If Samba has been built with asynchronous I/O support, Samba will not wait until write requests are finished before returning the result to the client for files listed in this parameter.
        ## Instead, Samba will immediately return that the write request has been finished successfully, no matter if the operation will succeed or not.
        ## This might speed up clients without aio support, but is really dangerous, because data could be lost and files could be damaged.
        #aio write behind = /*.tmp/

        ## lower CPU useage if supported and aio is disabled (aio read size = 0 ; aio write size = 0)
        ## is this still broken? issue is from 2019 (NOTE: see )
        ## (no, yes)
        #use sendfile = yes


I builded new firmware for our Stora. Based on OpenWrt 21.01 RC1 stable. New kernel, last version packages. Package update correct work. New firmware in folder 21.01.0-rc1. Need just update in LuCi

1 Like

I'll give it a go, I was going to try that my self. Will it break my drive mounts? I'll take a backup up FSTAB i guess..

@Nevskiy is your stora an MS-2000 or MS-2110? just out of curiosity? Mine is a MS-2110.

No, raid settings will be save.

My Stora MS-2000

@Nevskiy I have tried out RC1 a couple of times. Good idea to add USB in.

Is the package installer working ok for you? Its not working for me again?

src/gz openwrt_core
src/gz openwrt_base
src/gz openwrt_luci
src/gz openwrt_packages

------ UPDATE -----

I removed https and replaced with http.. working for me now?

Working is good.
my settings:

dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
option check_signature

src/gz openwrt_core
src/gz openwrt_base
src/gz openwrt_luci
src/gz openwrt_packages

@Nevskiy Might have been something weird on my end.

Its working now... just out of curiosity - can you successfully install package:


Its a dependency for mounting a USB drive... I get a conflict with the kernel version, which makes no sense because the kernel is current?

Hm... I have a too kernel incompatible version...


Hello! I builded for you firmware with this package

1 Like


So it works when you build from staging, but not when you install after the build?

Unfortunately, I don't know why it not install after staging. Maybe GURUs Openwrt will explain to us...