Netgear RAX10 not able to get IP adress for 2nd WAN interface


I used telnetenable to get access to the stock Openwrt firmware.
I can create and start the interface by entering the commands:
ip link add link eth0 name wan2 type vlan id 200
ip link set wan2 up

then trying to get an ip:
udhcpc -i wan2

This is the part were i get stuck: i keep getting 'Sending discover...'

It worked previously on an Asus RT-BE88U which is also broadcom based.
I am 100 percent sure eth0 is the the WAN interface as i checked it with both ifconfig and ip link. WAN Traffic is flowing trough that interface. The other eth interfaces (1-4) are 'down' (they have no cable connected).

There is some minor difference with Netgear vs Asus. The Netgear has his eth0 bridged to an 'brwan' interface which is actually the interface that holds the WAN ip. The ASUS didn't had a wan bridge. The WAN ip was on eth9.

So, what is missing on the Netgear that prevents it from getting an ip?

The RAX10 does not appear to be supported by the official OpenWrt project.

Since it appears to be running the vendor firmware, you'll have to ask Netgear for help.

1 Like

I've got it working, but i am unable to run binaries from Openwrt packages. Which architecture should i use? ARM Cortex A7 packages? They won't work on this router. It uses BCM6755. The BCM43xx and BCM63xx packages are also not working.

The router is running busybox 1.30.1, so i tried packages from Openwrt 19.07.x which also use this version.

This is entirely expected. As I said before:

And I also said that:

Ok, well i thought it would be easy because netgear is also using openwrt for stock firmware. So picking the right openwrt packages for the right architecture and version and it would be done. But this whole BCM platform is just not listed in the openwrt download page. I could ask at netgear forums but telnetenable is not officially supported i guess. I probably have to compile the packages myself.

Hope you got access to Netgear's "Openwrt" sources.

1 Like

To be clear, Netgear took (an old version of) OpenWrt and highly customized it for their device. That includes closed-source drivers for Broadcomm (which is why it's not supported here) and likely many other propriatary/custom additions for their product to function. The result is that it is not even remotely the same as official OpenWrt

Yes... but you will need to start with the SDK that they use -- hopefully they will provide it to you (the are supposed to). Futher, any support you require along the way will need to be directed to Netgear since, as I mentioned, the firmware and SDK for that device is not from the official OpenWrt project and cannot be supported here.

... and they will probably not answer.

1 Like

That's the SDK?

At first glance, it certainly looks like it. But who knows if it has everything necessary to build the firmware and/or other binaries for your router. That's not something we can support here, though. Go ahead and try it, but if it doesn't work or if you have questions, you'll need to follow up with them.

1 Like