Netgear R7800 stops sending beacons on 2.4GHz

I have an R7800 with OpenWrt 19.07.1 installed, which after some time (few hours) becomes invisible on 2.4GHz. The radio is still working, an 'iw scan' shows other AP's. It can be solved by restarting the wifi interface in Luci. This problem also showed up on 19.07.0. Don't know about older versions.

Does anybody know how to solve this, or how to work around? A way to detect the problem from the inside and restarting the interface would be fine.

Did you try the non-ct firmware? Search this forum for the steps: the default firmware does not work for me very well either.

No, I didn't try yet. I will do and report if it solved the issue.

Tried running other builds for the 7800?. Check out KONG's builds
KONG :+1:

Some delayed information. The non-ct firmware didn't solve the issue. Within 24 hours the AP vanished twice.

Then I changed the channel (from 1 to 13), the beacon interval (from default to 250) and the transmit power, and since then the AP is visible.
I know, it was not a good idea to change all at once, as I don't know which one solved the issue.