Netgear R7500v1 5GHz support

Does anyone know of a community build for the Netgear R7500 v1 hardware? Thank you.

Not sure there is a community build, but would be super easy for you to just install the OpenWRT provided image and then install what you want.

https://downloads.openwrt.org/releases/19.07.1/targets/ipq806x/generic/

1 Like

I am aware of that particular build but it says it does not support the 5GHz band. The comments section says that versions built with newer kernels would provide support, or that I would have to build my own version using the device source files that are provided elsewhere. I tried creating my own build environment, but with little time in my hands and two failed attempts to build a standard version of the firmware, I decided to ask if someone has already undertaken the task. But thank you for the quick answer.

It's not a matter of "community builds", OpenWrt currently does not know how to deal with the Quantenna Topaz wireless. Yes, it should be supported by qtnfmac in kernel 5.4, as already available via backports in current snapshots, but a) the module isn't packaged, b) the firmware isn't packaged and c) it's totally unknown what else (e.g. calibration data, MAC addresses, etc.) needs to be done to get it working or d) if it's actually supported by qtnfmac now. Once these things have been resolved and merged into OpenWrt, the device should be fully supported by stock OpenWrt - but this needs someone with the device to investigate it and to submit the necessary changes/ patches to OpenWrt. This won't magically happen, it needs doing.

1 Like

I certainly understand all that but given the device is not exactly new and there are lots of discussions about the open source firmware, and as you said, it seems it will be supported in kernel 5.4, I hoped someone had already done a port that is working. I guess I will have to wait longer.It is fine as it is not our main router.

I also wait for 5GHz support for this great model.

1 Like

I managed to build latest OpenWRT (master branch and kernel testing) with qtnfmac driver but it seems the firmware from stock (uboot) doesn't work (I tried all of them). In the dmesg it shows "FW runtime failure".

From https://patchwork.kernel.org/patch/10643357/ I knew that they haven't release the firmware officially. This driver just try to upload the uboot and boot from flash which didn't work.

1 Like

the same situation is with Linksys EA8350 - qtnfmac has to be build and tried.