[netgear r6100] Wifi (2.4) doesnt work

freshly installed openwrt 18.06.2 on my netgear r6100. Configured wifi (2.4, coz I dont have any 5Ghz devices) by following this guide: https://openwrt.org/docs/guide-quick-start/basic_wifi
Yet cant make it work.

It appears on the list of available connections on my linux laptop's networkmanager. But I cant connect to it - after about a minute of attempts, connection dies.
Double-checked passwords, double-checked country code, switched channels on router, switched mode to legacy - nothing helps.

Laptop's wifi works fine. Same goes for router - I've tried before installation and there was no issues with making wifi work. Router is accessible via wired connection.
No idea, what else to try. In case it may help - there is my networkmanager log (hopefully I've cleared all anyhow-personal information): https://pastebin.com/jTMQNadB

Can you connect with other devices (phone, tablet) ?
Post here the contents of wireless configuration as well as network and dhcp:
cat /etc/config/wireless ; cat /etc/config/network; cat /etc/config/dhcp

Check the lan network physical settings make sure the wifi AP is included in that network. It should not be in wan or any other network.

An Android device will show more about the network status. If the AP is up but there's a network problem, it will get stuck on "Obtaining IP address".


thanks, adding wifi to lan solved my issue

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like