Netgear GS308T v1 Installation Failure? (RTL838x)


The commit instructions say the OpenWrt ramdisk image can be flashed directly from the Netgear user interface, so that's the approach that I took.

I got the following snapshot image:

  • openwrt-realtek-rtl838x-netgear_gs308t-v1-initramfs-kernel.bin
  • 78dae1ecf17e73c0cc02dfef985079656a982bd0ab2eaf23f400da2968bef88e

And uploaded it to the switch (that had Netgear firmware to the first image slot via HTTP then rebooted the switch.

However after reboot I am not able to access the switch via SSH to proceed with the installation (scp sysupgrade, ..). The orange power light shines when it's powered on. I can not ping it. If I plug it into a different managed switch the port is shown as having link status of down.

Apparently the switch should be accessible on on all ports without VLAN according to Support for RTL838x based managed switches - #956 by svanheule

Regardless I used the following to try VLAN 100 on port 1 without success:

# ip link add link enp2s0 name enp2s0.100 type vlan id 100
# ip link set dev enp2s0.100 up
# ip addr add dev enp2s0.100

As far as I can tell I did what I was supposed to and did not make a mistake.

Anyone have some more recent experience with GS308T v1 or RTL838x switch to share some advice?

Thanks in advance!


Looking at the other threads on the forum:

  • no I did not accidentally flash openwrt-realtek-rtl838x-netgear_gs308t-v1-squashfs-sysupgrade.bin
  • i have tried port 1 with vlan 100 to no avail

At this point you will likely need serial access to the switch to determine where/what is failing. See the commit comments at;a=commit;h=c829bc1f2c3c47e230905864f2f5f8c759f88ce6 for how to access the serial port.

Got another GS308Tv1:

Again followed the guide for GS108Tv3:

Used OpenWrt 22.03 this time now that it's available (instead of SNAPSHOT):

  • 22.03.2 (r19803-9a599fee93)
  • 2022-10-15 14:53:47
  • openwrt-22.03.2-realtek-rtl838x-netgear_gs308t-v1-initramfs-kernel.bin
  • 5cb6a8e0d1e8d11a4b2c5fc0fc29500be846b0197da018f6c2b5a900ed2ad012

On a switch:

  • Model Name: GS308T
  • Boot Version:
  • Software Version:

This time it worked with no issues!

So either something was wrong with the SNAPSHOT image I used last time, or I got unlucky (as the GS108Tv3 wiki page says "This method sometimes fails.".

1 Like

Hi rodh3711

Thanks for Your guide - it helped a lot for a new openWrt user - though reading in general on the forum is very inspiring..

Only issue I ran into was when I after having flashed the initrams file, wanted to sysupgrade - I couldn't connect using ssh due to 'wrong password'. (edit forgot to access as root@ip-address)
But on the page ' Download OpenWrt Firmware for your Device' it says 'Use a Sysupgrade image to update a router that already runs OpenWrt. The image can be used with the LuCI web interface' and so I did - :+1:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.