Netgear gs308t v1 bricked snapshot

Hello, I recently upgraded to firmware openwrt and rebooted. Nothing works, orange light and no connection to any of the ports. No green lights, cable unplugged yet its not. I own gs308t-100NAS.

default ip was

I've tried \ 0.1 \ x.239 nothing. How can I revert back?>

The LEDs might be messed up. Are you sure there is no link detected? The default network config on the realtek target is confusing and hard to use. "LAN" is defined as VLAN 100 on port 1. Everything else is "WAN" and therefore firewalled to hell. The default address is the usual

BTW, which image did you install?


I've tried every port including, router lan > "wan" ports nothing. So I have flashed successfully apparently back to oem and still doesn't work but the thing is netgear supplies gs308t firmware as GS308T_310TP_V1.0.2.2.bix. So I see openwrt-realtek-generic-netgear_gs310tp-v1-squashfs-sysupgrade.bin

I'll give that a try soon. I'm just tired of trying over and over with no results.

Things to try

  1. openwrt-realtek-generic-netgear_gs310tp-v1-squashfs-sysupgrade.bin
  2. vlan 100 router port 4 to gs308t "lan" port 1
  3. changing host and gateway default ips

Which you flashed directly from the OEM firmware GUI? Then I guess your next step is to connect a serial console. I assum the GS308Tv1 is like the GST108Tv3. If so, then you have flashed a kernel without the rootfs. The OEM firmware silently cuts off anything following the initial uImage. Really stupid behaviour. They could at least have warned about an unexpected image size or something.

The only way to install OpenWrt from OEM firmware is by flashing an initramfs, and then sysupgrade from that. This works because the initramfs image packs both the kernel and the rootfs inside the uImage.

Unfortunately I don't see any way we can prevent a sysupgrade image from being accepted by the Netgear firmware, since the validation is pretty much the same the bootloader does. So anything bootable witl also be accepted by the stock firmware. And broken as described.

1 Like

No not from oem firmware gui, tftp64. I can't locate the server as it shows up unplugged. It will try to connect for a split second every few minutes. Can't even get a ping, at best request timeout when that happens. I'll try the initramfs after a smoke break.

Ah, OK. So then you have console?

What do you mean?

So it hasn't worked. It transfers or I might not be using the right server.

I've done it via tftp client, manually binded, 0.239, 0.1, etc

Good news and bad news, raspberry pi fixed since it was set to usb ssd boot before the update which messed things up.

Bad news, $90 down on barely used netgear gs308t-100nas. I need help can't afford to spend on a new switch. Could this help in someway?
Also figured out I was doing tftp wrong so the whole time via tftp client was towards my own ip which transfered to myself but not to the switch, won't work on powering on tftp server nor tftp client. I know how to tfttp done it many times on my archer c7 just thought I'd try tftp client which made me think it was successful. Hopefully led lights are bugged so how would I find the ip if thats the case?

I don't know this uprade method. I thought you needed console to use tftp in the bootloader. Was there a way to use tftp upload from the OEM firmware? If so, then that might have the same issues as their GUI flasher. Or did you follow any tested instructions when doing this?

It will be easy to fix as long as you can access it via console. You'll need a USB TTL adapter and solder a pin header. Some people have also reported success without soldering, pushing the pins against the solder filled holes, but I have no personal experience with that procedure.

Sorry that happened to you. The gs308t v1 has dual firmwares: . The following openwrt recovery procedure for devices with dual firmwares may be helpful:

  1. Switch device power off.

  2. 3x Switch device power on for 2 seconds, then off again.

  3. Switch device power on, the device should now boot to the alternative partition

I hope this works for you.

That can be worth trying, but I don't expect it to work on the GS308Tv1 or any other realtek switch.

AFAICS, the Realtek modified U-Boot does no accounting of fail/success. It simply boots whatever image the bootpartition variable points to. So you don't get much failsafe out of the dual partitions.

1 Like

Yes, I chose http. There was option to use image 1 and image 2. I used image 1. I haven't used any instructions, upgraded months ago from stock firmware to oem upgraded 1.0.01 or something like that no problems.

It hasn't. Anyways no lights show up on pc nor on the switch. Switch has solid orange power on. When plugged in the power cable, first second port 4 lights up green for a split second before solid orange power light is on. This could mean something right?

I don't know how to jtag but thats an option since the router is not pingable right? I can do the research when I have time just hope it doesn't require any scripts to write.

You are not bricked, but you will need serial access. As bmork indicated you'll need to access the switch via serial port and then stop uboot and change the boot partition to image 2. Once that is done you can then boot back into stock firmware and upload the image to partition 1. Boot again and use port 1 to access the switch for configuration. See Support for RTL838x based managed switches - #367 by slh for an example of how to access using a linux system. You would then need to sysupgrade to the image.

1 Like

I did not get that off bmork as you have, it registered differently and just assumption or googling whatever I don't understand. At least I got close with jtagging, but serial instead. Unless you just mean serial as lan port 1? Right now I'm not worried about this switch, I just got busy with a lot of work so I have time to mess around with this. I\d be happy for a detailed instruction I can donate $20 and maybe anyone in the future or currently facing saming problem as me instead of just buying a new switch. Best I can do or donate 10 strains of gourment mushrooms valued at $70cad free shipping competition price :wink: