Netgear DM200 / DSL training

Hi folks;

I have a Netgear DM200 running OpenWRT and I've noticed when the device reboots, sometimes it gets hung while DSL training. The system is still responding and I can access it via the serial console, but the DSL link stays in training status.

When this happens I can manually stop the dsl service, restart it, and usually it comes back up. Sometimes it requires a power cycle.

I tried to get more status with the dsl binary but i'm not too well versed in how it works or how to get more debugging information out of it.

On the stock Netgear firmware, this seems to work 100% of the time. This only happens when the device is running OpenWRT.

Is there anywhere I can look to get more debug information on the DSL link training? I tried looking in logread and there wasnt a lot of useful information in there because it only reports status once the DSL link comes up.

Are you using the DSL blob distributed with the standard OpenWrt images? If so, try extracting the DSL blob from a Netgear firmware and using that instead. Instructions for extracting the blob from OEM images can be found at (click "show downloads") but you'll have to identify a Netgear firmware to look for first or scan them all - there's definitely at least one Netgear DSL version there (but use a more recent Netgear image to get the latest blob). You'll need to use scp to copy the file onto the device and then put the full path to the file in the "firmware" option via LuCI - IIRC the usual location to use is /usr/lib/firmware but go looking for the existing blob first.


Thank you, i'll give it a shot!