Netgear AC2400 bricked. nmrpflash failed to recover

Device: Netgear AC2400

This was my first attempt at using OpenWRT. This is my first post on this forum.

I installed the OpenWRT firmware to my Netgear AC2400 router from my Ubuntu 20.04 system, following instructions carefully. Everything went as described in the instructions, except that it bricked.

I carefully followed all the instructions for using nmrpflash to restore the original firmware. Everything worked as described in the instructions, except that it's still bricked. Kinda sucks.

Any reprimands, advice, or consolation would be appreciated. Thanks for reading.

Can you provide more details?

What commands did you use to recover? What messages did you get during recovery?

Have you tried connecting to the serial port to see if there's any output?

1 Like

What was the output when you tried to revert using nmrpflash? Did it detect the router and attempt to flash it when you turned it on? Can you show a log of nmrpflash operating?


@VA1DER On screen the recovery process looked great to me. I copied the entire transcript in case anyone asked. Thanks for asking:

sudo ./nmrpflash -i enp1s0 -f AC2400_V1.2.0.92_1.0.1.img
Waiting for Ethernet connection (Ctrl-C to skip).
Advertising NMRP server on enp1s0 ... -
Received configuration request from 78:d2:94:7c:35:90.
Sending configuration:
Received upload request without filename.
Uploading AC2400_V1.2.0.92_1.0.1.img ... OK (29015810 b)
Waiting for remote to respond.
Received keep-alive request (88).
Remote finished. Closing connection.
Reboot your device now.

However, after I rebooted the router, it looked more dead than before the recovery (even less red lights). I repeated the process one more time just for good measure. Same result.

I have not checked the serial port for a heartbeat. I didn't realize that was a thing. I don't see a serial port or see any mention of one in the manual. Please advise.

What is the response on pinging Don't rely on lights only.
As for serial you need to open the case and connect a serial to USB adapter to these pins

R6700 2 and netgear Ac2400 are clones


When I put into my Firefox browser, I get:

The connection has timed out

The server at is taking too long to respond.

I will take a closer look at the serial port procedure soon.

This log proves that the bootloader is intact, and that nmrpflash was successfull. That being said, the issue can be elsewhere. I have learned recently (at my expense) that the "reboot your device" message doesn't mean that the flash process has ended. So the key here is to use a serial link, you'll be able to see the boot and nmrpflah process. When the flash process has ended (in the serial console, not your CLI), reboot. Monitor the boot and Netgear fw start. The issue may also lie in the netgear fw data.

1 Like

Wait at least 10mins before rebooting if you don't have a serial connection.
A serial connection will give you a better idea of what is happening.

As for serial this video might help

your serial port will look like this
a USB to TTL adapter, connect ground to ground.
RX to Tx
TX to RX.
Ignore VCC


@KOA Could this be the same reason why it failed to flash OpenWRT? If I could restore the original firmware by allowing the flash process to complete, perhaps then I can successfully flash OpenWRT in the same manner?

did you try tftp flash?

I re-flashed using nmrpflash and then let it sit for 20 minutes before rebooting. Still no sign of life. Pinging gives no result.

I did not yet try tftp flash. After watching the video, I'd say that process is above my technical ability.

did you flash stock firmware with nmrpflash? check it's default login IP, it is usually written at the bottom of the router.

As for TFTP, it can't be easier

1 Like

Yes it is possible, it depends on the device (some can, some can't). In your case it's an .img file so I tend to say yes.
When I say to wait for the flash process to end, it's about 1min. Not 10 or 20 :wink:
I still encourage you to monitor the flash and the boot process with a serial. That's the only way you can know what's really going on.

EDIT : there is also the possibility of bad blocks, so the flash process fails despite claiming it succeeds. Here again only a serial link will tell you.


Last night I attempted tftp flash using the instructions you mentioned. I followed every detail of the process. At the very end it says to remove power from the router for ten seconds, then plug it back in and wait for the power light to start flashing. It never started flashing. I unplugged and replugged several times waiting longer and longer for it start flashing. I attempted the flash anyway, with the stable red power light but the process timed out.

I attempted to flash stock firmware, yes. The default login IP is

Screenshot 2023-05-23 222348
Screenshot 2023-05-23 222454
this is how successful flash will look like with TFTP.

USB to serial TTL will give us the best idea of what is wrong. and it is not so difficult. just open the router and attach the wires as mentioned, start putty and wait for magical logs.


Would this USB to ttl adapter be a good one to use? I've never done this before so I want to make sure I am getting the right do-hickey.

No. Try this : CP2102 or 2104

1 Like

Are you saying that the Prolific PL-2303HX USB to UART bridge won't work, but the SiliconLabs USB to UART bridges will work. Am I understanding that correctly? If that's true, how can Prolific sell a device that doesn't work as advertised? Or are you just saying you've had better experiences with the SiliconLabs bridges?

It is usually different USB to UART chips work better in different applications. The one I used was based on CH340.