Need people testing ipq40xx DSA PR

I can do the conversion for you and send you an image to test.

Ok, I can test on the netgear. I wait for the image and will test
Thanks and regards

So is the AP1300 converted to DSA? I habe one and can test things if necessary. I am asking because there are no snapshot builds for it.

The dsa conversion is pending here: https://github.com/openwrt/openwrt/pull/10909

I did now a conversion here:

However, not sure if it works. I will build you an image where wifi is on by default and than you can test it.

Ah nice, I didn't see that one, only the PR that was closed.

Thanks and ok for me, I wait for the build and then I will test it (usually I have more free time during the weekends).
Regards

I uploaded some image here:

However, I just guessed what network conversion is correct. So it is not given that its really working.

Ok, i managed installing it, it says it is OpenWrt SNAPSHOT, r21917+1-cfb296b79a
At first I tryed a sysupgrade but didnt work at all. I've reset the extender and "openwrt" wireless came up, I manually edited the config files as before (dumb ap) and rebooted but I cant access internet I dont know why.

I can add the netgear_ex6100v2. Is the network working? What do you mean with internet?

Hello,
my network is configured like that:
A - Internet provider router (wifi turned off) @ip 192.168.1.1
B - GL.iNet GL-B1300 @ip 192.168.2.1 wan port is connected via cable to the provider's router lan port
C - Netgear Extender EX6150v2 @ip 192.168.2.2 connected via cable to B --> configured as "dumb ap"

I made the same configuration as with previous firmware version (22.03.3), but seems that I cant reach the internet. The extender is up btw. I will make other tests later, if you have something that you want me to verify pls tell me (im not that expert..).
Thanks

Did you set gateway and custom DNS ?
custom DNS can be the main router (B).

Hi, yes, this are network and dhcp files. I can confirm I reach 192.168.1.1 and I'm able to change to 192.168.2.2, login via ssh and edit the config files, but, even if configured correctly (to my knowledge) I cant access internet (on my linux client I get a "question mark" in the middle of the wifi icon, with pop-os).
Btw I've now resetted again.

/etc/config/network

        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7f:0d0d:34c2::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.2.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.2.1'
        option device 'br-lan'
        list dns '192.168.2.1' 

/etc/config/dhcp

        option domainneeded '1'                                                 
        option boguspriv '1'                                                    
        option filterwin2k '0'                                                  
        option localise_queries '1'                                             
        option rebind_protection '1'                                            
        option rebind_localhost '1'                                             
        option local '/lan/'                                                    
        option domain 'lan'                                                     
        option expandhosts '1'                                                  
        option nonegcache '0'                                                   
        option cachesize '1000'                                                 
        option authoritative '1'                                                
        option readethers '1'                                                   
        option leasefile '/tmp/dhcp.leases'                                     
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'                 
        option nonwildcard '1'                                                  
        option localservice '1'                                                 
        option ednspacket_max '1232'                                            
        option filter_aaaa '0'                                                  
        option filter_a '0'                                                     
                                                                                
config dhcp 'lan'                                                               
        option interface 'lan'                                                  
        option start '10'                                                       
        option limit '40'                                                       
        option leasetime '8h'                                                   
        option dhcpv4 'server'                                                  
        option dhcpv6 'server'                                                  
        option ra 'server'                                                      
        option ra_slaac '1'                                                     
        list ra_flags 'managed-config'                                          
        list ra_flags 'other-config'                 
        
config dhcp 'wan'                                                               
        option interface 'wan'                                                  
        option ignore '1'                                                       
                                                                                
config odhcpd 'odhcpd'                                                          
        option maindhcp '0'                                                     
        option leasefile '/tmp/hosts/odhcpd'                                    
        option leasetrigger '/usr/sbin/odhcpd-update'                           
        option loglevel '4'   

DHCP must be disable on the AP.
Are you able to ping main router (B) and ISP router (A) ?

Hi,i have ezviz router from list, it's my spare travel router and can play with it, serial adapter and spi programmer have too.

I've started from scratch after reset, and no, i'm unable to ping anything because what is happening is that the firmware is installed correctly, i'm able to access via "openwrt" wireless and configure the extender from ssh etc... btw I've discovered that when i plug a lan cable into it, it works for 1 second and then immediatly became unreachable and the wifi disconnect (if i'm logged in via ssh, the ssh shell just "freezes" and get stuck).