Need New DavidC502 Thread


#188

Thanks Dave for your reply - I did do this below as you suggested:

After you have changed the Gateway IP, on a windows machine do a ipconfig /release and then and ipconfig /renew and see if the gateway IP address has changed. If not, there may be one other place to edit.

Where might be that " other place to edit." ? - I ask this because I have been running your Builds for well over a year and I always followed ( including now on r7210 ) the practice you suggested and everything worked fine. Not this time however. Also do I only need to enter " key " for WPA2 on new Wireless Setup page? My main issue is with Lan not resolving - so if you can point me to that other edit - I will be most grateful.
Thanks again for your time and efforts

Peace,

directnupe


#189

Brainslayer says that 10.3.8.0-20180614 is completely broken on Mamba (v1). Any word on this?


#190

A changelog would be nice but if it takes too much of your time i can live without one. Just keep it up with ur great builds. :slight_smile:

And i'm happy with the new build as long as the wifi has been updated.
The only thing i haven't managed is to back up my settings and easy restore em.
I always boot the Linksys partition and flash your builds from there and then reconfigure everything from the scratch.
Anyway i dont have that much custom stuff running, only some custom firewall rules for my isolated guest network, dnscrypt-proxy, adblock, a few port forwards and a custom DynDNS provider.
It only takes about 10-15 mins for my setup and that's not a problem for me...
But it would be nice to save all my fw rules + interface settings and restore them but i'm not sure if it will work that way.

@All: (If you start from the scratch like me)Keep in mind to modify SQM so it will still work if WAN interface goes up and down / reconnects.
Details: [Solved/hotfixed] SQM does not reinitialize after ifdown/ifup


#191

Just skimmed through BrainSlayer's troubleshooting of mlwifi. It's a shame this driver still has so many issues, but he's amazing :slight_smile:

Anyway @BIOHazard87 if you skim further down that bug report yuhhaurlin said it was fixed in the new driver which davidc502 included in the new build.


#192

I don't think the driver to fix the AC1900 v1 is included in the build... looking at the notes the fixed driver is 10.3.8.0-20180615 - DavidC502 has 10.3.8.0-20180614...


#193

According to yuhhaurlin: fixed by 10.3.8.0-20180615.

Perhaps it wasn't fixed then. Wish davidc502 would make a new thread for his builds, his summary covering all the details of his build was very helpful. Besides this LEDE forum is far better/more advanced than the dead OpenWrt one was anyway.


#194

Hi folks, I successfully flashed David's latest build (7210) on my WRT32X last night and have everything working as hoped, with the exception of 160MHz wide AC. As soon as I change wlan0 from 80MHz to 160MHz the radio refuses to come up. Is this related to the bug mentioned re. mwlwifi driver? I'm quite happy with the 80MHz for now (only got 200Mb/s broadband anyways) but 160MHz would be nice to wring the most out of LAN speeds.


#195

@Kherby, let me share what I do:

A) I have a pre-update.sh script that copies key files into a directory that survives the upgrade ( in my case, it's a USB drive ). I copy over the dnscrypt-proxy black list that i have customized myself for example.
B) Do a backup of your configuration using the Luci interface (just as a precaution, you normally will not need this)
C) Do the upgrade with "keep settings"
D) I run my post-upgrade.sh script, that reinstalls everything:

opkg update; opkg install collectd-mod-conntrack collectd-mod-df collectd-mod-disk collectd-mod-iptables collectd-mod-netlink collectd-mod-ping collectd-mod-processes collectd-mod-protocols collectd-mod-sensors collectd-mod-syslog collectd-mod-tcpconns collectd-mod-uptime collectd-mod-wireless
opkg install collectd-mod-logfile kmod-fs-f2fs e2fsprogs cfdisk tar darkstat f2fs-tools vsftpd-tls bmon mailsend mpack ssmtp kmod-fs-cifs cifsmount kmod-ipt-ipset luci-theme-darkmatter luci-app-dnscrypt-proxy mtr collectd-mod-snmp snmp-mibs snmp-utils snmptrapd snmpd softflowd
/etc/init.d/darkstat enable;/etc/init.d/darkstat start; /etc/init.d/collectd enable; /etc/init.d/collectd start;
/etc/init.d/snmpd enable;/etc/init.d/snmpd start;
cp /mnt/sdb1/FTPServer/dnscrypt-blacklist-domains.txt /usr/share/dnscrypt-proxy
mkdir /mnt/NAS
mount.cifs //192.168.1.101/4TB_Disk /mnt/NAS -o unc=\\\\192.168.1.101\\4TB_Disk,ip=192.168.1.101,user=mariano,pass="yourSMBpassword",dom=workgroup
/etc/init.d/wait4mount enable
/etc/init.d/igmpproxy disable; /etc/init.d/igmpproxy stop
./install_bearDropper.sh
./install_sub2RBL.sh

nano /etc/firewall.user   

The last line is because you need to delete a line ( the last one ) for SUB2BRL that get's duplicated.

I'm pretty sure you know which packages you need to list in the installation script, but to make sure the first time, you can run the following script that will give you the list of all the packages installed in your system:

#!/bin/sh

FLASH_TIME=$(opkg info busybox | grep '^Installed-Time: ')

for i in $(opkg list-installed | cut -d' ' -f1)
do
    if [ "$(opkg info $i | grep '^Installed-Time: ')" != "$FLASH_TIME" ]
    then
        echo $i
    fi
done

Hope this helps... with this technique, I've went down from 15 minutes (as you're doing) to 5 or less.

Regards,
Mariano (long time @davidc502 fan)


#196

+1

@mariano.silva
Many thanks, i'll give it a try next time !!


#197

Anything in the logs to indication a problem? I've noticed wifi has to listen for radar before starting, and there have been a few times where it took 15 minutes to finally come up. I haven't had that problem on 80mhz or smaller.


#198

@davidc502 , quick question ( as this seems to be your NEW thread :slight_smile: ) . Why does the free space fluctuate on /overlay all the time with the router ( 1900ACS Shelby ) doing basically nothing?

Untitled
Screenshot is from my PRTG installation monitoring through SNMP

I have the following packages as suspects:

  1. DnsCrypt
  2. Busybox
  3. SNMPD
  4. COLLECTD (I'm saving the .rrd's on local ram ( /mnt/collectd ) ... this is the main suspect ... if collectd's output plugin collects the data for a certain period, and then rolls it up to summarize it, reducing the filesize ...

I'll do some more testing stopping Collectd ...


#199

I reply to myself: YES, the culprit was the RRD plugin from Collectd ... it uses up to 1.2 MB of disk space while buffering the stats, then rolls it up and consolidates them, and starts over. I just noticed this because I'm below 20% of space on /overlay :slight_smile:

Regards,
Mariano


#200

@davidc502 one thing that is definetivelly needed on your website is the BUILD number besides the Kernel version for the current release on the site! .... something like:

Kernel version = 4.14.48
WiFi driver = 10.3.8.0-20180614
Build: r7002

Also, to have people migrating from the openwrt forum to this new thread, you should update this:
Questions? Inquiries? Contact me over here https://forum.openwrt.org/c/community-builds-projects-packages


#201

Ah, now that's interesting. Didn't realise it could take so long to come up. I've only just been reading up on DFS and, guess what, I live under the flight path for an airport so it may take a while! Thanks for the advice...


#202

Og God, you're a genious @ListerWRT!!! I was scratching my head for weeks on WHY this was happening and now I know ... were you able to find a workaround on this or just reverting to a previous build? If so, which build is that?


#203

I miss my darkmatter... still broken ! If darkmatter didn't change in months, then the issue is with the Luci updates.


#204

Makes sense.

Done --


#205

We can keep everything going in this thread --


#206

Thanks! Great addition :wink:


#207

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.