Need help with R7800 and Luci/wifi connections going dead


I have 18.06.01 installed on my R7800 for the past few weeks. On 2 occasions I have completely lost access to wifi, no ssid broadcast etc... and I've completely lost the ability to access the LUCI web interface.

The first time this happened, I was able to reset and get my wifi working again. But this 2nd time, I'm completely stuck, I've tried rebooting a couple of times but still no Wifi/Luci. I can ssh in and access the cli, but I'm totally stuck here now.


TFTP push-button recovery should always be possible. While I don't have a r7800, my very similar nbg6817 has never showed any such issue so far.

The commands:


don't work?

slh, I can still ssh to the cli so I'm hoping that I don't need to recover in that way since it's not bricked.

lleachii, Thanks, that did work. I was just hoping to fix it without having to reset everything. I've had this happen twice already, so I feel like this is just going to be a monthly thing and I wanted to figure out just exactly what's breaking. I'm new to openwrt but I do need this to be moderately reliable =)

Thanks again, maybe someone else will know something and chime in...

1 Like

Completeley lost? Also via wired LAN connection ?????

1 Like

Yes, I couldn't connect to luci through the wired connection. I tried restarting the httpd service but that didn't help either. I had to execute firstboot to get luci ane wifi working again.

Is uhttpd process running? (the web server)
I assume that you are actually not using "httpd" but the default uhttpd...

When you restart the uhttpd service, what error messages pop up?

When that error materialises and you lose also wifi, what are the contents of system log and kernel log? (logread, dmesg)

Just saying that "it does not work" does not much give others clues how to help you. You need to provide logs. The might give some light.