Need help with OpenWrt on Asus RT-AC58U

Hey, guys. I'm new to OpenWrt and tried to install it on my Asus RT-AC58U V1 router. So I downloaded openwrt-r1834-0f04829-ipq806x-asus_rt-ac58u-squashfs-flash-factory.trx file that I found on this page: Then I flashed it on top of my default asus firmware, and everything looked fine, with only one problem that I couldn't upgrade it with openwrt-22.03.5-ipq40xx-generic-asus_rt-ac58u-squashfs-sysupgrade.bin file from the same page. While figuring this out I tried to config my LAN connection, so I could at least have internet working. So I went to Network > Interface > and edited lan setting putting my static IPs there. I think I changed default IP with my static one, and now I can't even connect to router anymore. I tried using and I tried using the one I put there, nothing works. Can someone help me to restore access to router? Thanks.

reset it ?

or set your client to an IP in the same subnet that your lan IP is set to.
disconnect the Asus from internet when you do this.

Sorry, reseting settings sounds good, but the guide you linked doesn't look detailed enough for me. I do have reset button on router, but holding it down for 10sec doesn't seem to do anything.

When OpenWrt boots, one of the leds start flashing about once a second. This lasts for 4-5 seconds and then continues to boot indicated by flashing slower. If you press any button on the router during these 4-5 seconds, it will start flashing rapidly indicating that you entered failsafe mode.

Then, you need to connect via an ethernet cable to Lan1, set up a static IP on your PC to 192.168.1.x where x is not 1, netmask (/24) and connect via ssh as root too When you connect via SSH you can type firstboot, confirm with y and then type reboot.

1 Like

Okay, I manage to restore access and config internet, so everything is working now. Thanks for the help.
Can someone point me to the right direction now of why I can't update it? It keeps giving me The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform. error. I was thinking maybe I can't jump from version 18 to 22 and if so where can I find some 19 or 20 for my router? Thanks.

The 1st FW you installed isn't from the official site.
This could also be why the reset behaved differently.
Since it's a documented way of installing, you should probably force the flash,
assuming you've followed the rest of the steps in the wiki.

1 Like

So, everything is working now and I have last official version installed. Thanks everyone for you help and time.
For anyone interested in the future for Asus RT-AC58U, you can't install official version from inside default Asus firmware. That's why I was using link above. This is the guide that helped me at the end:

that link is already on the AC58U wiki page ... ?

1 Like

Yes, it is. But I guess I'm just a little bit slow and was forced to jump here and there with all this link before figuring out what to do at the end :smiley: