Need help upgrading firmware on Seeed reRouter CM4 1432

Hello community! I just purchased a Seeed Studio OpenWRT Router based on the RPI compute module 4.

I am trying to update it using the GUI and also tried from SSH, no success :frowning:

I tried official Seeed studio images (sysupgrade images) and the install begins, I lose control of the router, and when I return to it, it has not updated...

How do you upgrade your OpenWRT routers?

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

That being said, your device is supported by OpenWrt. Please see the device wiki for your device here.

Thanks for the detailed response!

I will follow that guide and deploy a more "generic" image to test :slight_smile:
I will keep you informed.

I'm looking into the same issue. Have you tried the process described here:

1 Like

I ended-up following the generic RPI installation guide. The only issue I have with it is that it won't access the entire emmc storage... The is a fix fir that too but I did not have a moment to fix it.

Also, after installing the generic image I had a lot of plugins to reinstall and also the general theme (same used by Seeed... I liked it)

1 Like

Installing a fresh factory image (ext4, factory) likewise worked for me too.