[ need help] Trying to solve issue of having two public ip addresses

On my wan interface in openwrt i get an ip address from my isp of, but my real public ip when checking whatsmyip is

This is all when running my setup as (isp modemrouter combo in bridge mode) -->openwrt

When running the isp supplied combo unit as the only link in the chain I get as my both my public ip and the routers ip. So everthing works as expected.

Why is this happening and how could I could I go about solving it?

My two cents:

  • is reserved for carrier-grade NAT.
  • I guess the bridge mode in your modem is not a real bridge, can you reconfigure it?

I have some options for bridging actually, but all end with the same result.

  1. The one I'm using right now which is setting the the entire modem into bridge mode
  2. Setting individual ethernet ports into bridge mode which has this particular tooltip (Enabling bridging will allow any device connected to this particular Ethernet port to be directly connected to the WAN. The device will get an IP address directly from your Internet provider and not have access to your local network. Are you sure you want to continue?)
  3. Giving individual mac addresses connected to any ethernet port direct access to the wan and this is the tooltip for that (MAC bridging provides a mechanism for allowing devices on your LAN network to have a direct connection to the WAN. A bridged device will get an IP address directly from your internet provider and not have access to your local network.)

Unless I am mistaken, this modem has a weird concept of what means to act as a bridge...

How is the WAN interface configured on the OpenWrt router?

1 Like

The protocol is set to dchp client in the interface settings. Whenever I use any of the bridge modes I explained earlier the wan interface aquires an ip in the 100.something.range.

Perhaps someone else has a better idea, but I think that there is nothing that can be done from the OpenWrt router, this has to be solved on the modem.


One theory I have is that this has something to do with how my modem does iptv.

The reason being that the modem has 4 Ethernet ports and the second Ethernet port is always set to bridge mode to be connected directly to the Iptv android box. It could be that the iptv solution always expects to be connected to the Isp first with those 100.something.address then to the Internet.

Hence the reason why this modems definition of «bridge mode» always double nats me as it's expecting to be "bridging" to an iptv android device.

Don’t know If there is any truth to this, but it’s the best I’ve got right now

@TestingForSolutions8, welcome to the community!

I don't think you understand. The 100.xxx.xxx.xxx address are Private. They are used by ISPs when they do not issue public IP addresses to their user's end devices.

I don't think it's been made clear to you - that this means your title is incorrect; because you do not have two IP addresses. You have zero (for inbound usage that is, which is usually why people consider themselves as "having an IP").

A 100.xxx.xxx.xxx IP is unrelated to your wanting to properly bridge your modem...unless I'm misunderstanding.

1 Like

Yeah, I see that now. I didn't know 100.xxx.xxx.xxx where in the range of private adressesses. However the problem of the router assigning this 100.xxx.xxx.xxx whenever it's using it's definition of bridging would probably be the more apt desciption in this case, as the isp modem/router just assigns a normal 192.xxx.xxx.xxx whenever bridging is disabled in normal routing mode.

So to sum what is probably currently happning in my two modes of operation

  1. Normal routing mode with bridging disabled just hands out a private ip in the 192.xxx.xxx.xxx range and keeps the nat inside my isp/combo unit, but I do keep my public ip, for which I'm paying for.
  2. The bridge modes enabled hands out a private ip in the 100.xxx.xxx.xxx range and seems to send it offsite to my isps cgnat solution.

It seems like my routers definition of bridging is handing out a different private ip range and then just disabling the firewall or probably turning on dmz.

Of course I could be terribly wrong, but this apparent "bridge mode" my modem tells me it has is a bit weird

Ummm...depending on the last three octets, this is a private IP likely too.


Hold on...are you saying that you:

  • pay for a public IP
  • and the one your ISP told you is yours...is seen when in "normal routing mode"


If so, you need to talk to your ISP.

1 Like

When in normal routing mode and when I'm logged into the isp router/modems online portal I can see that the wan ip corresponds with what i find on lets say whatsmyip. This is with my isp router/modem as my only link in the chain.

However when I want to use my openwrt device in conjuntion I only get private ip addresses no matter if my isp router/modem is in bridge mode or not. I do understand that 192.xxx.xxx.xxx adressess are private as that is to be expected when not I'm running the isp/combo unit in bridge mode. but when I am in fact running the isp combo unit in bridge mode, I would really do like for the combo unit to passthrough my normal public ip to my openwrt device, rather than give me these 100.xxx.xxx.xxx private adressess.

What I really meant by this is that my combo/unit hands out private addresses of 192.xxx.xxx.xxx to other clients further down the chain (my openwrt device) when running in normal routing mode. Which is as it should, but I only included it as a summary of how the combo unit works in it's normal state.

Upstream from the isp combo units perspective it has the same wan ip as my public ip in this configuration.

Only 192.168.xxx.yyy are private, the rest of 192.xxx.yyy.zzz are public.

Does your modem have any "DMZ" configuration? Perhaps you cannot obtain a public address, but at least have all the ports redirected.

1 Like

Oh cool, I didn't know that. So whenever I've written 192.xxx.xxx.xxx, I actually meant 192.168.xxx.yyy as those addresses were private

Yeah it does, and I had been thinking of that as a solution if all else fails, but I had really hoped I could get my modem to just pass through the public ip as that would be a lot cleaner.

Can you elaborate more what modem you have and what type of connection you are using? And how did you enable bridged mode? FTTH/IPTV? It may be that only a specific port is meant to be bridged.

EDIT: I remember that some FritzBoxes had difficulties with certain FTTH-Modems in front running in bridged mode. That's why I'm asking.


It's a docsis 3.1 cable modem (TG3442S from arris) which also brings iptv over the connection

  • The modem has a big green button that I can toggle to turn the entire modem into bridge mode, which is the one I tested the most.
  • The second one I've tested is bridging individual ethernet ports (more on this below) on the modem which leads to the same results as bridging the entire modem (ie gives out the same private ip address range (100.xxx.xxx.xxx) as opposed to 192.168.xxx.yyy it hands out when not bridging.

Yeah, the modem comes preconfigured with the second ethernet port in bridged mode, and the documentation tells you to plug the iptv android box into that port or else it won't work. However if you put any of the other 3 ethernet ports into bridged mode and plug the iptv box into that you get will get the same result (working iptv).

What's actually funny is that if you use the toggle to bridge the entire modem, you can plug the iptv box into any of the ethernet ports and have it work too (It seems to just bridge all of the 4 ethernet ports at the same time if I use this toggle). So that tells me that all of the bridging options my isp modem gives me ends with preconfiguring the ports to give out 100.xxx.xxx.xxx addresses which coincidentally is what makes the iptv box work

I have the feeling this bridge mode is not a lets say "full" bridge mode. Here in Germany the big cable providers forcing you to set bridge mode in customer service center in addition to the settings on the router. What means they are dropping firewall on your end.

Sometimes they are making this setting for you on the router also. Because they blocked the function/buttons on the router itself.

I would bet it is running i a so-called pseudo bridge ... Even my Cable FritzBox 6591 has no real bridge mode. :confused: My guess is that (my FritzBox is running a so-called eRouter grabbing an IP) your router is grabbing one of your public IPs or saving one for your IPTV Box.

I would recommend to verify if bridged mode is available/activated properly asking your provider.


Yeah, if everthing goes according to plan I'm going to ask them tomorrow. Heres to hoping I can get past tier 1 help desk (unless they can help, in which case I'll be pleasantly surprised)

1 Like

Turns out you were right @pwned, my isp needed to put the combo unit into bridge mode on their side, rather than I toggling it on mine.

Now I have a public ip available from my openwrt router :smiley: so this one is solved.

For anyone who comes across this in the future, even if your modem has a bridge mode it's probably wise to call your isp the moment you get a result that's anything else than what you expect, to save yourselves hours of troubleshooting and running into a wall.

Just for completeness sake, this was with the norwegian isp Eidsiva with their altibox iptv solution, and using their docsis cable modem partner brand Arris.


Glad to hear. It is pretty common that ISPs don't let the customer decide to bridge their modems nowdays. Even in the past you had to "hack" your modem to get it into bridged mode (with more or less work).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.