Need help setting up Samba

I'm pretty new to LEDE and I've been pulling out my hair for the last few days trying to set up a samba share off my 8 bay non-raid enclosure on my wrt3200acm.

I was using the stock Linksys firmware just fine, and then all of a sudden it stopped working properly with ext4 formatted drives. I know ext4 isn't officially supported by Linksys but it did work. I tried using my wrt1200ac and it had similar problems. No firmware update- just stopped working. I know the drives are still 100% because I was able to mount them and open a few files connected to my PC.

OK, so here's where I'm at with LEDE: Under the GUI all 5 of my ext4 drives are shown under mountpoints, correct sizes, everything, so I assume they're mounted properly. They're all enabled.

In network shares I set:

pathname (ie: Media)
path /mnt/sda1
Allow guests checked

When I access it at in Windows 10 explorer, the Media folder is there but it's empty. Any ideas? This is basically just a makeshift NAS so I can watch movies on my Shield TV.

Please have patience with me. I have fooled around with Ubuntu a bit, but I'm basically learning as I go.

I appreciate all the help.

Can you ssh into the router and run ls -la /mnt/sda1

kmod-fs-ext4 installed?

I figured it out. The Linksys firmware screwed up my drives. All my ext4 drives had invalid superblocks. I had to use gparted and do a check on them to fix it.

When I run a check on one them it hangs up gparted when it goes to apply the fixes. Is there a way I can do this from SSH/LEDE? I don't want to lose the data on the drive. Any other way would be useful. I tried a few different mini-Linux installs of Gparted, Gparted Magic, etc and they all got hung up.

Edit: Nevermind, it's doing it again. I'm about ready to throw in the towel. All the ext4 drives are showing as empty- when clearly they're not. I reverted back to Linksys firmware- same deal, ext4 all empty, NTFS drives, fine.

Same problem on the wrt1200ac I have, I tried even mounting the drives in a different enclosure, same problem, both routers. Since it worked fine before I have no idea what's going on.