Good evening!
Long time lurker (Yah'll have helped me with wireguard, zerotier, the switch from 19 to 21, and many other things beside. And more recently the forums here have gotten me to the point where I can connect my cellular modem)
Problem:
Succesfully connected to Cellular Internet via Modemmanager.
Can't move packets across the cellular interface.
Not even with ping -I mhi_hwip0 8.8.8.8
Details:
I have a snapshot build (no choice) running on BPI-R4.
I am aware this is not optimal, I apologize.
I have a modem, "RM520NGL-AP" on m.2 PCIE.
Network:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd48:8ffb:5949::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'eth1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ip6assign '60'
list ipaddr '192.168.254.1/24'
config device
option name 'br-wan'
option type 'bridge'
list ports 'wan'
list ports 'eth2'
config device
option name 'wan'
option macaddr 'aa:9c:32:9c:41:3c'
config device
option name 'eth2'
option macaddr 'aa:9c:32:9c:41:3c'
config interface 'wan'
option device 'br-wan'
option proto 'dhcp'
config interface 'wan6'
option device 'br-wan'
option proto 'dhcpv6'
config interface 'cellularwan'
option proto 'modemmanager'
option device '/sys/devices/platform/soc/11280000.pcie/pci0003:00/0003:00:00.0/0003:01:00.0'
option apn 'mobile.three.com.hk'
list allowedauth 'pap'
option iptype 'ipv4v6'
option loglevel 'ERR'
mmcli -m 0
------------------------------------
General | path: /org/freedesktop/ModemManager1/Modem/0
| device id: 3fbbcfd2c2c508ba6b0b4060bb87cdb38d56cd03
------------------------------------
Hardware | manufacturer: generic
| model: RM520N-GL
| firmware revision: RM520NGLAPR01A04M4G
| carrier config: ROW_Commercial
| carrier config revision: 0A010809
| h/w revision: RM520N-GL
| supported: gsm-umts, lte, 5gnr
| current: gsm-umts, lte, 5gnr
| equipment id: 868371050010962
------------------------------------
System | device: /sys/devices/platform/soc/11280000.pcie/pci0003:00/0003:00:00.0/0003:01:00.0
| physdev: /sys/devices/platform/soc/11280000.pcie/pci0003:00/0003:00:00.0/0003:01:00.0
| drivers: mhi_net, mhi-pci-generic
| plugin: generic
| primary port: wwan0mbim0
| ports: mhi_hwip0 (net), mhi_swip0 (net), wwan0mbim0 (mbim),
| wwan0qcdm0 (ignored)
------------------------------------
Status | lock: sim-pin2
| unlock retries: sim-pin2 (3)
| state: connected
| power state: on
| access tech: lte
| signal quality: 48% (cached)
------------------------------------
Modes | supported: allowed: 3g; preferred: none
| allowed: 4g; preferred: none
| allowed: 3g, 4g; preferred: 4g
| allowed: 3g, 4g; preferred: 3g
| allowed: 5g; preferred: none
| allowed: 4g, 5g; preferred: 5g
| allowed: 4g, 5g; preferred: 4g
| allowed: 3g, 5g; preferred: 5g
| allowed: 3g, 5g; preferred: 3g
| allowed: 3g, 4g, 5g; preferred: 5g
| allowed: 3g, 4g, 5g; preferred: 4g
| allowed: 3g, 4g, 5g; preferred: 3g
| current: allowed: 3g, 4g, 5g; preferred: 5g
------------------------------------
Bands | supported: utran-1, utran-4, utran-6, utran-5, utran-8, utran-2,
| eutran-1, eutran-2, eutran-3, eutran-4, eutran-5, eutran-7, eutran-8,
| eutran-12, eutran-13, eutran-14, eutran-17, eutran-18, eutran-19,
| eutran-20, eutran-25, eutran-26, eutran-28, eutran-29, eutran-30,
| eutran-32, eutran-34, eutran-38, eutran-39, eutran-40, eutran-41,
| eutran-42, eutran-43, eutran-46, eutran-48, eutran-66, eutran-71,
| utran-19, ngran-1, ngran-2, ngran-3, ngran-5, ngran-7, ngran-8,
| ngran-12, ngran-13, ngran-14, ngran-18, ngran-20, ngran-25, ngran-26,
| ngran-28, ngran-29, ngran-30, ngran-38, ngran-40, ngran-41, ngran-48,
| ngran-66, ngran-70, ngran-71, ngran-75, ngran-76, ngran-77, ngran-78,
| ngran-79
| current: utran-1, utran-4, utran-5, utran-8, utran-2, eutran-1,
| eutran-2, eutran-3, eutran-4, eutran-5, eutran-7, eutran-8,
| eutran-12, eutran-13, eutran-14, eutran-17, eutran-18, eutran-19,
| eutran-20, eutran-25, eutran-26, eutran-28, eutran-29, eutran-30,
| eutran-32, eutran-34, eutran-38, eutran-39, eutran-40, eutran-41,
| eutran-42, eutran-43, eutran-46, eutran-48, eutran-66, eutran-71,
| utran-19, ngran-1, ngran-2, ngran-3, ngran-5, ngran-7, ngran-8,
| ngran-12, ngran-13, ngran-14, ngran-18, ngran-20, ngran-25, ngran-26,
| ngran-28, ngran-29, ngran-30, ngran-38, ngran-40, ngran-41, ngran-48,
| ngran-66, ngran-70, ngran-71, ngran-75, ngran-76, ngran-77, ngran-78,
| ngran-79
------------------------------------
IP | supported: ipv4, ipv6, ipv4v6
------------------------------------
3GPP | imei: 868371050010962
| enabled locks: fixed-dialing
| operator id: 310410
| operator name: EIOTCLUB
| registration: home
| packet service state: attached
| pco: 0: (partial) '270480000000'
------------------------------------
3GPP EPS | initial bearer path: /org/freedesktop/ModemManager1/Bearer/0
| initial bearer ip type: ipv4v6
------------------------------------
3GPP 5GNR | mico mode: unsupported
| drx cycle: unsupported
------------------------------------
SIM | primary sim path: /org/freedesktop/ModemManager1/SIM/0
| sim slot paths: slot 1: /org/freedesktop/ModemManager1/SIM/0 (active)
| slot 2: none
------------------------------------
Bearer | paths: /org/freedesktop/ModemManager1/Bearer/1
Route:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 10.40.134.17 0.0.0.0 UG 0 0 0 mhi_hwip0
10.40.134.0 * 255.255.255.224 U 0 0 0 mhi_hwip0
192.168.254.0 * 255.255.255.0 U 0 0 0 br-lan
Dmesg and syslog to follow
I'd apprecciate any thoughts or insights!