Need help reading the bootlog for Linksys E2500v3 to solve

There are many threads here and on Reddit regarding after flashing the E2500v3 (and other versions too) that the LAN is dead and there is no IP address. I was able to connect via serial and get the bootlog and the configs for network, dhcp, firewall, and interfaces.

Does anything look out of place? What else is recommended I try on the terminal?

Bootlog:

CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
Build Date: 08/01/13 19:16:00 CST (lzh@team2compiler2)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.
This is a Serial Flash
Boot partition size = 262144(0x40000)
Found a 16MB ST compatible serial flash
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.60.127.2901 @VERSION_TYPE@
CPU type 0x19749: 300MHz
Tot mem: 65536 KBytes

CFE mem:    0x80700000 - 0x807A2670 (665200)
Data:       0x80735190 - 0x807391B0 (16416)
BSS:        0x807391B0 - 0x8073C670 (13504)
Heap:       0x8073C670 - 0x807A0670 (409600)
Stack:      0x807A0670 - 0x807A2670 (8192)
Text:       0x80700000 - 0x80735184 (217476)

Boot version: v6.07
The boot is CFE
Nothing...
The country is same

### CLKDIV= 0x80e0842, SFlashClkDiv=8 clkdivsf=2 ###

### Change it to 0x20e0842 (2) ###
Device eth0:  hwaddr B4-75-0E-C5-EA-E5, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
  Header CRC:    0xA30A1A1B
  Calculate CRC: 0xA30A1A1B
Image 1 is OK
Try to load image 1.
Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
Loading: Failed.
Could not load :: Timeout occured
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: .. 3816 bytes read
Entry at 0x80001000
Closing network.
Starting program at 0x80001000
[    0.000000] Linux version 5.4.188 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16554-1d4dea6d4f)) #0 Sat Apr 16 12:59:34 2022
[    0.000000] CPU0 revision is: 00019749 (MIPS 74Kc)
[    0.000000] bcm47xx: Using bcma bus
[    0.000000] (NULL device *): bus0: Found chip with id 0x5357, rev 0x02 and package 0x08
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] This processor doesn't support highmem. -65536k highmem ignored
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000]   HighMem  empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16240
[    0.000000] Kernel command line:   noinitrd console=ttyS0,115200
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes, linear)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 58724K/65536K available (4888K kernel code, 180K rwdata, 576K rodata, 168K init, 298K bss, 6812K reserved, 0K cma-reserved, 0K highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 128
[    0.000000]  bcm47xx_soc: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x26, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x1C, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Core 2 found: GBit MAC (manuf 0x4BF, id 0x82D, rev 0x03, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Core 3 found: MIPS 74K (manuf 0x4A7, id 0x82C, rev 0x04, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Core 4 found: USB 2.0 Host (manuf 0x4BF, id 0x819, rev 0x05, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Core 5 found: DDR1/DDR2 Memory Controller (manuf 0x4BF, id 0x82E, rev 0x02, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Core 6 found: I2S (manuf 0x4BF, id 0x834, rev 0x02, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Core 7 found: Internal Memory (manuf 0x4BF, id 0x80E, rev 0x0B, class 0x0)
[    0.000000]  bcm47xx_soc: bus0: Found M25FL128 serial flash (size: 16384KiB, blocksize: 0x10000, blocks: 256)
[    0.000000]  bcm47xx_soc: bus0: Early bus registered
[    0.000000] MIPS: machine is Unknown Board
[    0.000000] bcm47xx: Setting up vectored interrupts
[    0.000000] random: get_random_bytes called from 0x80586a2c with crng_init=0
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 12741736309 ns
[    0.000022] sched_clock: 32 bits at 150MHz, resolution 6ns, wraps every 14316557820ns
[    0.000152] Calibrating delay loop... 149.50 BogoMIPS (lpj=299008)
[    0.032150] pid_max: default: 32768 minimum: 301
[    0.032631] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.032692] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.039812] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.039882] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.042075] NET: Registered protocol family 16
[    0.098860] clocksource: Switched to clocksource MIPS
[    0.101760] thermal_sys: Registered thermal governor 'step_wise'
[    0.102725] NET: Registered protocol family 2
[    0.103298] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.105315] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.105420] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.105488] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.105543] TCP: Hash tables configured (established 1024 bind 1024)
[    0.105871] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.105951] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.106640] NET: Registered protocol family 1
[    0.106757] PCI: CLS 0 bytes, default 32
[    0.616343]  bcm47xx_soc: bus0: Bus registered
[    0.625896] workingset: timestamp_bits=14 max_order=14 bucket_order=0
[    0.646811] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.646976] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.688370] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.694020] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.700293] printk: console [ttyS0] disabled
[    0.720681] serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 2, base_baud = 1250000) is a U6_16550A
[    1.192659] printk: console [ttyS0] enabled
[    1.230878] random: fast init done
[    1.287578] 3 bcm47xxpart partitions found on MTD device bcm47xxsflash
[    1.294296] Creating 3 MTD partitions on "bcm47xxsflash":
[    1.299891] 0x000000000000-0x000000040000 : "boot"
[    1.314842] 0x000000040000-0x000000ff0000 : "firmware"
[    1.322780] 3 trx partitions found on MTD device firmware
[    1.328423] Creating 3 MTD partitions on "firmware":
[    1.333578] 0x00000000001c-0x000000000948 : "loader"
[    1.347204] 0x000000000948-0x0000001d4400 : "linux"
[    1.356575] 0x0000001d4400-0x000000fb0000 : "rootfs"
[    1.364409] mtd: device 4 (rootfs) set to be root filesystem
[    1.370358] 1 squashfs-split partitions found on MTD device rootfs
[    1.376790] 0x0000004f0000-0x000000fb0000 : "rootfs_data"
[    1.392312] 0x000000ff0000-0x000001000000 : "nvram"
[    1.408844] bgmac_bcma bcma0:2: Found PHY addr: 30 (NOREGS)
[    1.457846] b53_common: found switch: BCM5325, rev 4
[    1.463245] bgmac_bcma bcma0:2: Support for Roboswitch not implemented
[    1.474769] bgmac_bcma: Broadcom 47xx GBit MAC driver loaded
[    1.481289] bcm47xx-wdt bcm47xx-wdt.0: BCM47xx Watchdog Timer enabled (30 seconds)
[    1.492954] NET: Registered protocol family 10
[    1.510206] Segment Routing with IPv6
[    1.514412] NET: Registered protocol family 17
[    1.519240] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.532518] 8021q: 802.1Q VLAN Support v1.8
[    1.547743] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    1.556556] Freeing unused kernel memory: 168K
[    1.561211] This architecture does not have kernel memory protection.
[    1.567830] Run /sbin/init as init process
[    2.793394] init: Console is alive
[    2.797599] init: - watchdog -
[    4.422718] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.624975] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.643568] init: - preinit -
[    8.062381] random: jshn: uninitialized urandom read (4 bytes read)
[    8.333434] random: jshn: uninitialized urandom read (4 bytes read)
[    8.501516] random: jshn: uninitialized urandom read (4 bytes read)
[    8.807048] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    8.823120] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   13.655510] jffs2: notice: (405) jffs2_build_xattr_subsystem: complete building xattr subsystem, 8 of xdatum (0 unchecked, 3 orphan) and 9 of xref (3 dead, 0 orphan) found.
[   13.673770] mount_root: switching to jffs2 overlay
[   13.682079] overlayfs: upper fs does not support tmpfile.
[   13.697941] urandom-seed: Seeding with /etc/urandom.seed
[   13.952007] procd: - early -
[   13.955389] procd: - watchdog -
[   14.807110] procd: - watchdog -
[   14.812158] procd: - ubus -
[   14.959624] urandom_read: 1 callbacks suppressed
[   14.959643] random: ubusd: uninitialized urandom read (4 bytes read)
[   14.976709] random: ubusd: uninitialized urandom read (4 bytes read)
[   14.984506] random: ubusd: uninitialized urandom read (4 bytes read)
[   15.000513] procd: - init -
Please press Enter to activate this console.
[   17.955519] urngd: v1.0.2 started.
[   18.128602] kmodloader: loading kernel modules from /etc/modules.d/*
[   18.214961] Loading modules backported from Linux version v5.10.110-0-g3238bffaf992
[   18.222880] Backport generated by backports.git v5.10.110-1-0-g1fbde860
[   18.345236] xt_time: kernel timezone is -0000
[   18.614972] crng init done
[   18.617765] random: 3 urandom warning(s) missed due to ratelimiting
[   18.664228] PPP generic driver version 2.4.2
[   18.680925] NET: Registered protocol family 24
[   18.787911] b43-phy0: Broadcom 5357 WLAN found (core revision 28)
[   18.802933] b43-phy0: Found PHY: Analog 9, Type 4 (N), Revision 9
[   18.809239] b43-phy0 ERROR: FOUND UNSUPPORTED RADIO (Manuf 0x17F, ID 0x2057, Revision 5, Version 2)
[   18.818619] b43: probe of bcma0:1 failed with error -122
[   18.824454] Broadcom 43xx driver loaded [ Features: NL ]
[   18.883354] kmodloader: done loading kernel modules from /etc/modules.d/*
[   53.005645] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   53.028725] br-lan: port 1(eth0.1) entered blocking state
[   53.034393] br-lan: port 1(eth0.1) entered disabled state
[   53.041100] device eth0.1 entered promiscuous mode
[   53.046121] device eth0 entered promiscuous mode
[   53.062015] br-lan: port 1(eth0.1) entered blocking state
[   53.067657] br-lan: port 1(eth0.1) entered forwarding state
[   53.891744] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready



BusyBox v1.33.2 (2022-04-16 12:59:34 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.3, r16554-1d4dea6d4f
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:/#

Network:

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd45:f566:361c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 5t'

DHCP/DNSMasq:

root@OpenWrt:/# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Firewall:

root@OpenWrt:/# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
        option name             Support-UDP-Traceroute
        option src              wan
        option dest_port        33434:33689
        option proto            udp
        option family           ipv4
        option target           REJECT
        option enabled          false

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

Interface:

root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::b675:eff:fec5:eae5/64 Scope:Link
          inet6 addr: fd45:f566:361c::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:3078 (3.0 KiB)

eth0      Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          inet6 addr: fe80::b675:eff:fec5:eae5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5737 errors:0 dropped:0 overruns:0 frame:0
          TX packets:542 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:656041 (640.6 KiB)  TX bytes:93666 (91.4 KiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:3078 (3.0 KiB)

eth0.2    Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          inet addr:10.9.8.201  Bcast:10.9.8.255  Mask:255.255.255.0
          inet6 addr: fe80::b675:eff:fec5:eae5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2720 errors:0 dropped:0 overruns:0 frame:0
          TX packets:129 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:265815 (259.5 KiB)  TX bytes:10792 (10.5 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:420 errors:0 dropped:0 overruns:0 frame:0
          TX packets:420 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:34127 (33.3 KiB)  TX bytes:34127 (33.3 KiB)

LAN Status:

root@OpenWrt:/# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 2085,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "fd45:f566:361c::",
                        "mask": 60,
                        "local-address": {
                                "address": "fd45:f566:361c::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

Looks normal at first sight... Can you test with a 22.03 image? This looks to be 21.02 still.

22.03 did successfully upgrade:

root@OpenWrt:/# cat /proc/version
Linux version 5.10.138 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 11.2.0 r19685-512e76967f) 11.2.0, GNU ld (GNU Binutils) 2.37) #0 Sat Sep 3 02:55:34 2022

Unfortunately the same situation. WAN is working, but no LAN.

root@OpenWrt:/# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 268,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "fd22:aa73:acab::",
                        "mask": 60,
                        "local-address": {
                                "address": "fd22:aa73:acab::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::b675:eff:fec5:eae5/64 Scope:Link
          inet6 addr: fd22:aa73:acab::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:2044 (1.9 KiB)

eth0      Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          inet6 addr: fe80::b675:eff:fec5:eae5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2781 errors:0 dropped:0 overruns:0 frame:0
          TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:312141 (304.8 KiB)  TX bytes:25810 (25.2 KiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:2044 (1.9 KiB)

eth0.2    Link encap:Ethernet  HWaddr B4:75:0E:C5:EA:E5
          inet addr:10.9.8.201  Bcast:10.9.8.255  Mask:255.255.255.0
          inet6 addr: fe80::b675:eff:fec5:eae5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2488 errors:0 dropped:0 overruns:0 frame:0
          TX packets:186 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:242629 (236.9 KiB)  TX bytes:15786 (15.4 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:33 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3753 (3.6 KiB)  TX bytes:3753 (3.6 KiB)
root@OpenWrt:/# ifup lan
[ 1222.315370] br-lan: port 1(eth0.1) entered disabled state
[ 1222.342074] device eth0.1 left promiscuous mode
[ 1222.346723] device eth0 left promiscuous mode
[ 1222.351735] br-lan: port 1(eth0.1) entered disabled state
[ 1222.536166] br-lan: port 1(eth0.1) entered blocking state
[ 1222.541817] br-lan: port 1(eth0.1) entered disabled state
[ 1222.548242] device eth0.1 entered promiscuous mode
[ 1222.553282] device eth0 entered promiscuous mode
[ 1222.620373] br-lan: port 1(eth0.1) entered blocking state
[ 1222.626028] br-lan: port 1(eth0.1) entered forwarding state

This is strange, since the wan and lan run through the same CPU port and hardware switch.

Run swconfig dev switch0 show to see which switch ports are up and if VLANs have been properly loaded into the switch.

Ok so here's the switch configuration:

root@OpenWrt:/# swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
        ports: 0x003f
Port 0:
        pvid: 1
        link: port:0 link:up speed:100baseT full-duplex auto
Port 1:
        pvid: 1
        link: port:1 link:down
Port 2:
        pvid: 1
        link: port:2 link:down
Port 3:
        pvid: 1
        link: port:3 link:down
Port 4:
        pvid: 2
        link: port:4 link:up speed:100baseT full-duplex auto
Port 5:
        pvid: 0
        link: port:5 link:up speed:100baseT full-duplex
VLAN 1:
        ports: 0 1 2 3 5t
VLAN 2:
        ports: 4 5t

#0-3 are the 4 LAN ports, #4 is the WAN port. Does it look right?

SUCCESS!

Ok I figured out that for some reason you can't use VLAN1 which is default:

root@OpenWrt:/# uci show network.@switch_vlan[0]
network.cfg081ec7=switch_vlan
network.cfg081ec7.device='switch0'
network.cfg081ec7.vlan='1'
network.cfg081ec7.ports='0 1 2 3 5t'

Change the LAN to VLAN3 from VLAN1 on the switch and the br-lan device:

root@OpenWrt:/# uci set network.@switch_vlan[0].vlan='3'
root@OpenWrt:/# uci set network.@device[0].ports='eth0.3'
root@OpenWrt:/# uci commit

Changed:

root@OpenWrt:/# uci show network
network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdc5:c8bd:a468::/48'
network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='eth0.3'
network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.wan=interface
network.wan.device='eth0.2'
network.wan.proto='dhcp'
network.wan6=interface
network.wan6.device='eth0.2'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].ports='0 1 2 3 5t'
network.@switch_vlan[0].vlan='3'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='4 5t'

@rmilecki Can you please change to VLAN3 for the LAN so the E2500v3 is again a working device for the community?

I'd definitely prefer to have VLAN 1 support fixed instead.

What can I do to help try or test?

This is really strange. This is ancient history but I thought the BCM5325 switch core was also sold as a separate chip which was used in several OpenWrt compatible routers with non-Broadcom CPUs.

You're right that is a separate switch chip and it shows as that but I checked and that chip isn't on the board so it's integrated into the CPU

Reading this it's mentioned that some devices have VID1 reserved - could it be that this is that scenario?