Need help on WAN ethernet link aggregation

Hi, there:
I am pretty new to openwrt and need your help on setting up WAN aggregation.

My ISP is Comcast, my modem is ARRIS SB8200, which has two WAN ports.
According to its spec, SB8200 supports Link Aggregation. I already enabled the Link Aggregation on my modem.

My Openwrt is installed on Dell Inc. OptiPlex 7040 Intel(R) Core(TM) i5-6500 CPU , version OpenWrt 23.05.2

I googled some videos, but all of there are about aggregating two ISP.

Let me know any information you need.
I will be grateful if you guys can give me some guidelines.

thanks in advance.

This is my current network configuration.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda2:255e:9b44::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

Link aggregation, bonded pair; it has a couple different nomenclature.

It is, usually, a way to take two slow channels and bond them into one with double the bandwidth.
It can be used to use two different ISPs for redundancy.

Are both wan ports in use?

Hi, thanks for your quick reply.
Right now , i have 3 ports in my PC. eth0 is used for lan, eth1 is used for wan. eth2 is not used at all.
Do you mind send me several links for reference?
Do not know how to do these "Link aggregation, bonded pair ". Also do not know how to convert eth3 to 2nd WAN.

thanks a lot.

Then you are not using the option: you can use speedtest.net to check it both on an off.

Just to make sure you're not wasting time/energy, a few quick thoughts:

  • What is your internet speed? If it is <= 1Gbps, you won't benefit from LAG/bonding.
  • Are both ports active (or easily configured to be active) as a LAG/bonded pair?
  • On your Dell, you said you have 3 ethernet ports -- are they all 1Gbps, or are they faster? Assuming you have >1Gbps internet service, you'll need a way to access that on your lan... so you'll need at least one >1Gbps ethernet interface and/or multiple 1Gbps interface. And your downstream equipment would also have to match this -- either multiple switched paths, or a core switch with a >1Gbps interface.

You can still certainly setup the LAG/bond even if you won't benefit downstream, but at that point it is really just an academic exercise (and all good if it is -- learning is great).

1 Like

Right now, my current set up is:
modem -> eth1 (WAN)
eth0 -> 8 port switch , switch -> 1. my linux server; 2. Unifi U6 LR AP.

Do you mind sharing general idea how i can do the link aggregation?
Some useful links are definitely helpful. thank you.

I assume what i need do
1 convert eth2 to a WAN port ( do know how.. :unamused:.)
2 connect two cables from model 2 ports to the two WANs
3 config link aggregation( do know how :unamused:)

Well, since your ISP does not offer you a second wan line I don't see how to do that.

thanks for your reply. Please see my comments inline.

  • What is your internet speed? If it is <= 1Gbps, you won't benefit from LAG/bonding.
    [A] my current plan is 500mbps comcast. are we saying if <1gbps, it does not increase the speed through aggregation? Why?
    I thought with link aggregation, i will get 500mbps * 2 = 1Gbps.

  • Are both ports active (or easily configured to be active) as a LAG/bonded pair?
    [A] right now eth0 and eth1 are active. eth2 i just configured it to LAN. My original plan was eth0 and eth2 set up as WAN, and link them together so i can get 1GBPS total.

All the three ports are 1gbps ports. My switch is also 1GB switch. So i thought 500mbps x 2, all my ports can still handle the traffic.

  • On your Dell, you said you have 3 ethernet ports -- are they all 1Gbps, or are they faster? Assuming you have >1Gbps internet service, you'll need a way to access that on your lan... so you'll need at least one >1Gbps ethernet interface and/or multiple 1Gbps interface. And your downstream equipment would also have to match this -- either multiple switched paths, or a core switch with a >1Gbps interface.
    [A] my current set up all 1GBPS ports. However, my newly purchased devices are on the way, including 2.5GB switch and two 2.5GB network card.

oh, are you saying, i need a 2nd wan line from comcast, in order to do this?

It is what I am saying.

@psherman may be talking about how to do it on the lan side, just to learn about it, but I lack that knowledge.

No... you pay for your internet service based on the speed tier you desire. If you pay for 500Mbps, the cable company will give you 500Mbps. That is the speed between their headend and your modem -- nothing is going to increase that unless you are paying of a higher tier of service (or in some cases, they may increase the speed at some point in the future for the same price, but let's just use the 'now' part of the equation).

As described above, you're not going to improve the speed they deliver to your modem.

Your modem's interfaces are 1Gbps each, so unless you've got more than 1Gbps bandwidth from the ISP, the local ethernet connections have enough bandwidth such that they are not a bottleneck.

At some point in the future, these could be useful... but until you are subscribed to a >1Gbps service tier, they will not provide any additional value relative to the 1Gbps interfaces you currently have (unless you have VLANs and are doing a lot of inter-vlan routing).

okay, got it. thanks for your reply.
So , with my new 2.5GB card and 2.5G switch, is it possible to improve my LAN speed?

Well, that depends on a number of factors. Generally, the answer is likely no, it won't make a difference (at least in the near term).

  • Do your other devices have >1Gbps interfaces?
  • Do you have VLANs and if so, do you have a large volume of traffic that is routed from one VLAN to another?

Assuming a network topology of (which I assume, based on your original idea of bonding two ports for wan):

[modem] <--> [router]` <--> [2.5 GBit/s switch] <-+-> [2.5 GBit/s client]
                                                  |
                                                  +-> [2.5 GBit/s client]
                                                  |
                                                  +-> [2.5 GBit/s client]
                                                  |
                                                  +-> [2.5 GBit/s client]
                                                  |
                                                [...]
                                                  |
                                                  +-> [2.5 GBit/s client]
                                                  |
                                                [...]
                                                  |
                                                  +-> [1 GBit/s client]

Your inter-LAN traffic remains within your 2.5 GBit/s switch and never touches the router (or your WAN), so any 2.5 GBit/s capable clients connected to your 2.5 GBit/s capable switch will immediately profit from 2.5 GBit/s (to its full extent) when talking to each other, obviously they can only talk to your older 1 GBit/s clients at 1 GBit/s - or to the internet at 500 MBit/s (based on the maximum of your contract).

1 Like