Need help, fried on board NIC

I'm facing a really weird issue right now and I'm not sure which way to go... I'd appreciate whatever ideas you might have cuz I'm out of any :face_in_clouds:

I was replacing fans on my gpu and somehow static electricity managed to kill my motherboard lan slot...

It's gone 100000% , not in device manager not in network adapters just pooof....

Anyways I bought usb nic , plugged it in and the internet worked for solid 30 seconds then it cut off... and the loop repeats itself like that, whenevr it cuts off the pc reports no cable connected ( It also cuts of during speedtest every single time , runs for 2-3seconds and then website spits out this error: bad sockets , check firewall bla bla... I can see the adapter icon change to no cable connected , so the error is prolly bs...)

What might be dead? My motherboard or the CPU?

Does NIC communicate to CPU directly or does it go through motherboard NIC first?

Can you tell us how this is related to OpenWrt?

I run openwrt on that device xd

For anyone encountering same issue, I moved usb nic to the front port...

God knows what else is fried back there, so far 0 packet loss and connection looks stable, still curios as to how far the damage might have gone?

Localised to motherboard only , since front port seems to have fixed it?

Ah... that wasn't clear, especially when talking about a GPU which is unnecessary with OpenWrt (maybe you're running OpenWrt in a VM?).

You should probably consider replacing the entire motherboard... ESD damage can be unpredictable in terms of what damage occurs, and beyond that, your motherboard may have latent damage that will fail at some later point.

I keep a gpu there for instances like these xd

Fire up windows and either stuff works or it doesn't :stuck_out_tongue_closed_eyes:

It's a relief that it "works" for now, I was checking out am4 motherboard and only 150$ and above models are available

I'm off to update other forums :joy:


you're welcome... good luck!