Need Assistance with bricked Archer C7

Model: Archer C7
Hardware Version: V2
Firmware Version:
Hello

I have bricked my Archer C7 .

While searching for a solution I tried to use the TFTP method to bring it back to life .

It seems its stuck ( or in boot loop ) after it tries to boot .

I downloaded many firmwares recommended versions - yet I cannot get is work (I assume that due to this error )

"auto update firmware: product id verify fail!"

I tried manipulating the Product ID to 0Xff as described in
https://community.tp-link.com/en/home/forum/topic/151859

but changing 0X40 to 0X47 did not change the product ID .
Tried few options for guessing the place yet it did not work

Tried those 2 options as well

Any help will be highly appreciated

Logs from the router for my all attempter FW upgrades are below :

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1c)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: ######
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = ffffffff
 recovery_product_ver = ffffffff
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: ##########
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = c7000002
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: ###########
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = c7000002
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: ########
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = c7000002
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: T ##################
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = c7000002
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: #########################
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = c7000002
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1c)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: ########################
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = c7000002
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: #################################
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = c7000002
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: ######################
done
Bytes transferred = 16252928 (f80000 hex)
original_product_id = 00
 original_product_ver = 00
 original_resvered_id = 00
 original_special_id = 0000;4555000
 recovery_product_id = ffffffff
 recovery_product_ver = 01
 recovery_resvered_id = 00
 recovery_support_list =
 compare special,ret:0
auto update firmware: product id verify fail!
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

U-Boot 1.1.4 (Aug  3 2017 - 16:39:33)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1b)
Tap values = (0xf, 0xf, 0xf, 0xf)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:xx:yy:zz
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:xx:yy:zz
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
dup 1 speed 1000
Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: ##############

I remember bricking this router about 5 - 6 years ago. It was a US regoin router. What worked for me was to TFTP factory image with uboot, downloaded from TPLink web site. It was either build 150520 or 161031. I don't remember which one I used. Looking at TPLink website (Canada) they now have 170525, 180114, and 180305 available. Did you try any of them?

See if you can find 3.14.3 Build 151014, which is what I have, and it works.

It needs to be renamed to ArcherC7v2_tp_recovery.bin to work with TFTP.

None of them worked I am getting
auto update firmware: product id verify fail!
Of each one I am trying....... :cry:

Did not find this one but tried Archer_C7_v2_150304 as well as Archer_C7_V2_V3_141110

With every each one of them I get auto update firmware: product id verify fail!

The later version of stock firmware may be refusing to downgrade. I assume your ultimate goal is to run OpenWrt not stock. Since you have serial I'd suggest manually tftp the initramfs OpenWrt into RAM and boot it, then sysupgrade. That is about the safest way to debrick.

@mk24

Can you give some more info or reference to the process?
BTW : tried few OpenWRT FW as well

Thx in advance

Tried downloading all the Archer C7 V2 fw in the following link ( including initRamFS)
https://downloads.openwrt.org/releases/19.07.8/targets/ath79/generic/

Unfortunately nothing works I get "product id verify fail!"
Nothing seems to work

Download the initramfs kernel and the sysupgrade OpenWrt. Put the initramfs in your tftp server directory with a short name like 'initramfs.bin'
Get to the u-boot prompt (paste 'tpl' to the serial console when "Autobooting in 1 seconds" appears)
At u-boot, run
tftpboot 0x82000000 initramfs.bin
You should see a bunch of # signs as the file transfers.
Then run
bootm 0x82000000
OpenWrt should boot. This is a one-time copy of OpenWrt running entirely in RAM. It will have default settings, including IP of 192.168.1.1
On your PC, scp the sysupgrade image to the router:
scp openwrt-xxxx-sysupgrade.bin root@192.168.1.1:/tmp
Then back on the router flash it with sysupgrade:
sysupgrade /tmp/openwrt-xxxx-sysupgrade.bin

Thanks a lot for the detailed information @mk24
Unfortunately I think I am beyond that point .
Nothing which I do let me go into Uboot Ram mode.
Tried multiple times yet it goes to
" Uncompressing Kernel Image ... OK

Starting kernel ..."

Nothing halts this operation so I guess this is real brick
Anything else can be done?

Thx

Type "tpl" somewhere and cut that text. Select the serial terminal window and power up the router (don't hold the reset button). When "Autobooting in 1 seconds" appears, hit ctrl-V to paste "tpl" to the serial port.

If that does not work, some TP-Link models need a small hardware modification to accept input from the serial port.

This is exactly what I did.
Nothing happens .....
Tried it multiple times , so I assume it's not timing issue.
What should I look for ? ( might be Archer C7 ) needs this HW teak ?

Thanks a lot for your help so far

You can check this link: Need Modified Image Archer C7 v2 Product ID Verify Fail Bricked/Bootloop

@S.Farid

Tried downloading the FW as well as installing the mini FW but nothing helps
I still get same error - TMHO this is the problem as this time as TFTP method seems to work
"auto update firmware: product id verify fail!
Autobooting in 1 seconds"

I had the same problem a month ago and after trying TFTP with every image I could find without success I had to hex edit the version id myself to get it to work. Give it a try

I'm 99% its the stable openwrt but it could be snapshot so you may have to SSH.

Cheers!

@S.Farid @w000000t @mk24
Gents,
Thx so much for your assistance
I managed to get it working
Used this method:
Downloaded the FW from here :https://github.com/danielschmalhofer/Important-Openwrt-Things
Had to manipulate the HW ID using Hex editor ( Changed it to 0X0 instead of FF)
And used the method described here :https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500#tftp_recovery_de-bricking
After which I got HW ID verify OK and the firmware upgraded .
I had to update the package using CLI in order to install LUCI
https://forum.openwrt.org/t/need-modified-image-archer-c7-v2-product-id-verify-fail-bricked-bootloop/67576/12
Now the router is back to life
Thx for your time and efforts
LLAP

Thank you too. Glad that your router works again. Goodbye.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.