Need a favour from you clever people

Hello everyone, hope you all had a good Christmas.

I'm attempting to install hnymans build of openwrt to my r7800 router... But I've hit a wall due to lack of knowledge but I can't seem to find the answer on Google either...

Installed no problem, I'm in the UK on a VDSL fibre connection, I have a separate modem with Ethernet cable into the r7800 wan port, so once openwrt had loaded I changed the wan to pppoe connection, added the username and password and hey presto my PC had internet...

But I run my network at home as static IP addresses as lots of devices use certain things for storage or content however on the openwrt menu I can't seem to find out how to get it done? I found static addresses under the dhcp menu, added the Mac addresses, gave them the IP addresses and saved it, that side of things worked as it showed them on the router in the right locations but it lost my internet connection to everything?

It did ask in the static set up, about lease time and DUID but I didn't know what I needed to add for either so left them blank.

Can I have openwrt run with only 29 static addresses and none via dchp? Is there a guide?

Any tips?


Static IP addresses are configured at the user devices without any participation of the router. The devices must each be configured to use the router IP as a gateway to the Internet. They must each be configured for a DNS server.

What you are talking about is DHCP reservations. When a request comes from a certain MAC address and / or hostname, the router knows to issue it a pre-set IP address. The user device makes a regular DHCP request. The only difference is that the DHCP server in the router issues a pre-set IP instead of a random one.

Setting up reservations should not affect your Internet access. You should troubleshoot the network more closely. For example, does the router itself still have Internet access (use the network diagnostic page). Are the client devices receiving proper DHCP configuration?

Yes that's right, reservations would do the job, I just need a certain Mac address to always be at a certain IP address. Where abouts in the LuCi menu system can you find that option??

I loaded the router from stock, added the pppoe option to the wan and entered my user details, internet works on the PC. I then went into the DHCP section and under the active leases was a list of devices connected, under that menu was a section called static leases, into this section I added the Macs and IP addresses I wanted, hit save and apply. Upon a reboot no more internet.

The pppoe still shows as connected on the wan.

This seems like the right procedure. Unless you tried to use the wrong IP addresses, it should work as expected. What are the IP addresses of the router, the LAN's network segment, and the addresses you are trying to assign?

I get the feeling openwrt is a bit much for me, I'm lost already. It's so user friendly on stock firmware shame it's so buggy.

My modem is into the wan port, it's set up as pppoe.

The router IP is and I was assigning each of the Mac addresses an IP from upwards sequentially from a list.

That's the limit of my knowledge, I'll try find a local openwrt guru who can take a look for me, or maybe a config file to try lol

That should work, did you restart the network on the client devices?

Yes I tried restarting the devices. But nothing worked, Ethernet, built in wifi or the Ethernet wifi devices.

Reset the config, readded the pppoe bit and it all worked again just without the static addresses.

I'm now back on stock just to have the internet so I can ask you lot questions and do more research.

On openwrt, in the static IP section there's a few extra boxes I left blank, lease time, and one called DUID which says it's something about IPV6... Did I need to fill that section in??

Fastest way for you to understand what is going on would be to go and statically assign:


to a client.......

test it.... ping... ipconfig/ifconfig.... nslookup/dig....

then web search for "dhcp reservation openwrt guide"........

NOTE: the reboot -> no internet symptom raises the possibility that you are modifying "router" parameters..... and not dhcp ones.... so when there is no internet.... you need to dig a little.... go to the status page and veryfy that dns gateway ip are as they should be...... or web search for some guides in openwrt internet testing..... yes... may be a bit detailed for where you coming from but understand what you are doing is network administration........ a device..... is merely that..... and the dumbing down of core operations is great for the average joe..... alas, providing robust capability comes with the trade off of complexity.... and thus, as you've done here.... you gotta dig a bit....... learn a bit...... you'll be grateful you did.... cause those skills can resolve a majority of a home internet issues or lead to more skills that empower you.....

be clear on the issue, be clear on the angle of attack...... and stay logical..... you'll figure it out.

i can assure you that what is happening there is not a bug. i do concur with you though about the ui being a little unwieldy when it comes to dhcp.

as an intermin workaround... seeings as so many clients have services.... setting up the dhcp server
with reservations/"static LEASES" on one of those devices ( simple third party utility? ) would get you over this obstacle while you figure it out.

When running an IPv4 network be sure to click over to the IPV6 tab on the lan dhcp server and disable IPv6 server and RA. It is enabled by default, which can cause IPv6 capable clients to take a v6 address that goes nowhere, then they have no Internet.

I've never heard of this, unless you are advertising global addresses. ULA addresses should be ignored as src address for reaching the internet. Can you confirm that you've tested this and it caused problems? What client OS?

I can also say that for quite a while I had two Linux servers on an ipv4 only network with an openwrt firewall advertising ULA addresses and it didn't cause problems at all.