NanoPi R5C - Rockchip RK3568B2 - 2 PCIe 2.5Gbps

In reality you won't be able to get Intel WiFi card to work as AP in 5GHz/6GHz band.

…and let's be honest, in practice you can't get away without 2.4- and 5 GHz coverage either, which means three radios/ cards necessary (to some limited extent DBDC is possible, but that still means two radios, as there are no 'TBTC' cards, yet).

maybe it will take years for the official openwrt source code to support 5rc, before that, it will be a normal mini router with stock/factory firmware only.

It's because of linux mainline support is not there yet, without that OpenWrt can't do much.

1 Like

Support for the RK3568 is available in the 6.2 and 6.3-rc1 branches so progress is being made. None of the NanoPi R[56] based devices have been submitted yet but the Radxa E25 router DTS was added for 6.3-rc1.

1 Like

I've had an R5C for only a couple of days but I'm running @mj82 OpenWRT build on it with kernel 6.1 and so far so good. I was able to flash it just fine from a FriendlyWRT SD card image using their built in eMMC flash program.

I checked the Image. So far it is working.

But for R5C wifi is not supported. How do you install the wifi drivers?

Sorry my R5C doesn't have wi-fi so I haven't tried that.

Does eth1 (wan) show up for you? Only eth0 (lan) shows up for me.

No issues with the ports for me. Are you running FriendlyWRT or the above OpenWRT build?

Sorry for not having been more specific: Yes, with the above OpenWRT build, as of last night PT, my NanoPi R5C wouldn't detect eth1. Doesn't show up anywhere in the logs even.

With FriendlyWRT the interface shows up, so seems to not be a hardware issue.

Interestingly, I tried Debian for the device. It misdetects my device as R5S and two interfaces show up. If I manually apply the R5C config, then only one interface shows up. Wondering if that might be related. Details: Maybe there are (slightly) different versions of the hardware?

Sounds like it might be the configuration for the R5C to me. The last few builds mj82 have put out have been syncing the config to 5.15 so there might be something there.

I haven't updated mine to the latest build so I'm not too sure and I installed it a while ago and have been keeping setting the whole time so I might not ever see the issue.

I’m not sure how much this helps but I flashed the latest kernel 6.1 OpenWRT build from the above GitHub with “keep settings” and the ports are still working.

Thank you for letting me know, I do think this info will be useful to others who end up here after google'ing for the same problem. It does seem that my device works for kernel 5.10, but not 6.x, whereas others report 6.x kernels work for them (cf this Github issue).

1 Like

have no idea what's wrong with your device tbh.
the only cause i could think is the ethernet driver, can you post kernel log here?

btw, you may also try our firmware which is based on openwrt snapshot + kernel 5.15:

1 Like

Does your firmware have a lot of packages installed or is it pretty lightweight?

Just like the official openwrt firmware, only necessary packages are included by default.

1 Like

I started running the ImmortalWRT snapshot yesterday and can report no issues with it so far.

Of course you have to install luck after the fact or customize the image on their firmware selector page.

So... is there any card that would potentially work and provide 2.4/5Ghz in AP mode. I was aiming for 802.11ac and up to 1300 Mbps over wifi. Thanks.

Finally ported it to openwrt mainline, see

any review/test would be appreciated