NanoPi R4S rk3399 R6S RK3588S 4G is a great new OpenWrt device

Did you make any changes to SQM or turn it on/off? It seems that restarting SQM or just turning it off/on resets the cpu affinity to default. So if you were doing tests with SQM off and then on, you would have to re-run the commands each time. But under normal circumstances where you turn SQM on and leave it alone, I think running the commands in rc.local should be enough.

1 Like

True i did change sqm settings to see if there were any changes to the ping spikes! And end up turning on and off a few times.

Sorry, I meant to mention that in the other post but forgot.

rc.local runs at the end of the boot sequence, so in theory it should run after the SQM script. But if you want to make sure, you could put a "sleep 10" or something in rc.local before the commands.

1 Like

Thanks. Can you add a note that if you restart SQM or change SQM settings, it resets the cpu affinity and the commands need to be re-run.



Thx for all the work and tests you did so far... Clarifies so much.

So far the community for this device is amazing, true collaboration in this thread right here :smiley:

Users engage, brainstorm, test and share :+1:

Added warning in. Poke if you want any other changes etc or you can apply for a wiki account to do edits here :

1 Like


Also about sqm, this nice page which might contain something that could help with the ping spikes:

There is also this basic one:

I am giving a read now to see if i can figure out something!

Nice job with the wiki of our device :+1:


Just an FYI. DSL report servers are flaky/non responding at times. I suggest using Waveforms Servers instead and use DSL Reports as backup.

1 Like

The wiki for the R4S is still evolving really. Definitely rough around edges but its got key info there and also means its searchable and links back to this thread.

i ninja'd half of it from FriendlyArms pages and then had to manually convert things as they use a different wiki system. Redoing tables from scratch sucks.

1 Like

Thx for the info :+1: but i knew it already :smiley:

For me, dsl reports only works if i use the non-https mode, otherwise it does not matter what i do, it does not work at all :confounded:

1 Like

I'm following your posts, awesome work that you've been doing here! Congrats! :clap:t2:

Same here. I subscribed the thread. Honestly, it makes a lot of mails daily, but that's worth it and a pleasure to read them and see things go well.

Many thanks for all your work and sharing it :pray::+1::rocket:

Thanks for that and for the build.
Installed today and it solved my IPv6 issue and port forwarding works as it ought to. With the other build from github, 2 ip6tables were missing (got errors when trying to add) and I had to have a workaround to see a server from within the LAN.
Hopefully, we'll have an official release and I can update and add packages at will. Until then, your build is solid.

Specific to our device yes! Bugs related to openwrt itself no, like upnp being broken :smiley:

Ah, yeah, im talking only about openwrt compatibility with our device. We only need to wait for next stable openwrt release now.
Have you tried installing package (ipk file) from 21.02.1?
You could also compile package yourself in openwrt build env and change sources to use the same sources as 21.02.1 version of this package uses.

Today's snapshot (also latest imagebuilder) should contain reboot fix (exactly disable uhs uSD mode) patch.
Just remember that now it uses firewall4 by default. In my opinion is to use old firewall if you want stability and compatibility with all openwrt software. If you want to build image with old firewall adjust packages like in this commit but in reverse

Yes, downloaded from here:

but still:


Now its seems to be working! Had to download these 3:


Will next official build include all patches that are already in anaelorlinski build (R4S 1gb boot, sd card,...) ?

I don't have 1gb version so i don't know if official build works on such machines. But starting from yesterday official build includes sd card reboot fix.

1 Like