Nanopi R2S plus out & 4 year review of R2S

Hardware opinion: Buy a R2S or R2S plus (just out!) for a home router. Its cheap and fast

I've had an R2S running OpenWrt R2S for nearly four years now. I've used it as my main house router and its worked a treat. Two gigabit ethernet ports which run at high speeds (although my ISP gives me ~500 MBits) and tested LAN speeds are always > 900 Mbits. 1 GB of RAM allows me to run a router and all the network monitoring I want. Mostly just bandwidth graphs and vnstat. Relatively modern CPU - Rockchip RK3328 which does all i need v quickly.

I keep hearing people say that a dual ethernet board is expensive or they keep fiddling with a raspberry pi (with a ethernet HAT or USB2/3 dongle). Don't do it. I've run FriendlyWRT (their openwrt fork) then moved to openwrt. No problems, everything works.

Its also £41 for a board plus case plus postage. A 4GB raspberry pi with USB3 ethernet is not far off £100. And you are unlikely to get full GBE performance. RPIs also need a noisy fan which a nanopi doesn't. I love an RPi but its not a router...

China prices are $30 for the board and $6 for the case.

Cons:

  • Apparently getting wifi to work is a nightmare. I run ubiquity AP's so no idea. The new R2S plus allow a M2 card (RTL8822CS)
  • I had a SD card fail on me so now have a 'recent backup' ready.
  • I now run my bandwidth and data onto dedicated USB sticks rather than the SD card which makes it look a bit hacky but it works well (no failures for the last two years!).
  • one of the ports is a USB3->Ethernet and i've had no issues here with speed or anything but it feels hacky.
  • Armbian never worked well but that was three years ago.

I've bought the new R2S plus and am waiting for the OpenWrt image.

I'm writing this to basically say there is nothing cheaper that just works. Hardware is simple to install and all the images come with full working drivers and software installed so you just plug it in and load up a browser to tweak (you can SSH too). A gig of RAM is oceans of space for an OpenWrt image too.

Reviews with more details on R2S

R2S plus review

Wiki with loads of software and hardware details
https://wiki.friendlyelec.com/wiki/index.php/NanoPi_R2S
https://wiki.friendlyelec.com/wiki/index.php/NanoPi_R2S_Plus


Written with StackEdit.

1 Like

I own R2S/R4S/R6S, all of them are pretty good one.

First I would clarify that, RPi4 has much better processor than R2S, so routing in full GbE performance is just a piece of cake on Pi4, usually people getting trouble because of selecting a bad USB3 NIC (like those ASIX based model, if you use Realtek one it's just the same as R2S), but yes nowadays the Pi4 is still very expensive, 1GB model (hard to buy, seems to be at least 2GB now) + case + USB NIC I would say the R4S definitely beat it. I only recommend people using it when they have extra Pi4 on hand, using Geekworm metal case should be good enough, completely passive cooling works well.

R2S by default doesn't have WiFi, so if you install USB WiFi (not recommended for serious usage) you need to do some manual config, I won't say it's nightmare, most of the time is how you find a proper driver to work with it, and it has only USB2 port which won't bring you very good experience (well, using 802.11n 2.4GHz one can make a travel router use case here).

Upstream support on RK3328 is good (thanks to Google) so Armbian should work well on it now, but I believe most people want to use it as router so OpenWrt should be default choice, and of course using the vanilla OpenWrt, not FriendlyElec version.

Probably due to USB NIC, my R2S won't get me a very solid gigabit experience, ~800Mbps NAT LAN to WAN throughput is OK. For the extra processing power I inserted an old USB 2.0 SanDisk Curzer Fit 8GB memory stick (I have a few of them abandoned for some years) then ran PiHole inside LXC!

P.S. They also have R2C, which is similar platform but using USB-C power + another unsupported NIC so don't buy it, however when I received my R2S and I found USB-C power on it, thought they might have shipped me wrong one but in fact they already changed the design to use USB-C power (which is nice).

5 Likes

Thanks for the detailed post.
Have you run sqm on your 500mbps plan r2s?

No I didn't, since I don't quite need SQM for my internet here.

1 Like

I just bought a R2S Plus, I wonder can I use R2S firmware for this one? https://openwrt.org/toh/friendlyarm/nanopi_r2s

It should work fine for now - but remember that the new features like emmc, m2 slot and debug console won't work

1 Like

Thank you, I think I'll wait.

I used the Friendlelec openwrt image and the EMMC upload module works.

https://wiki.friendlyelec.com/wiki/index.php/NanoPi_R2S_Plus#Official_image

1 Like

It's normal that their image will work, but then you can't use the official OpenWrt image.

Any luck getting that R2S plus build going? I see just R2S and R2C builds on the latest release.

Hey i was wondering the same how to get a Openwrt Image for the R2S Plus.
Or how to Build one?

have you tried booting the r2s image on an uSD card?

1 Like

Oh hi. No still just using Friendlyelec image. Its on the todo list to upgrade the router OS but I'm waiting for OpenWRT 24. I have no idea if my problems are OpenWRT related or just my incompetence.

However the router has had no issues for months now.

yes we tried this. But after the Flash nothing happens (No LEDs blink) :confused:
Flashing the Friendlyelce image or debian image works fine

any chance you can get a console log ?

I've flashed openwrt-23.05.0-rockchip-armv8-friendlyarm_nanopi-r2s-squashfs-sysupgrade.img to my SD-Card and tried to boot up the nanopi r2s plus. Sys-Led is not blinking and shows an steady green light. The console log over serial port gives the following output (Lan port not connected):

DDR version 1.16 20190528
ID:0x805 N
In
DDR4
333MHz
Bus Width=32 Col=10 Bank=4 Bank Group=2 Row=15 CS=1 Die Bus-Width=16 Size=1024MB
ddrconfig:14
OUT
Boot1 Release Time: May 13 2019 17:34:36, version: 2.50
ChipType = 0x11, 248
mmc2:cmd19,100
SdmmcInit=2 0
BootCapSize=2000
UserCapSize=29600MB
FwPartOffset=2000 , 2000
mmc0:cmd5,20
SdmmcInit=0 0
BootCapSize=0
UserCapSize=60906MB
FwPartOffset=2000 , 0
StorageInit ok = 201722
Raw SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit ret = 0, SecureMode = 0
atags_set_bootdev: ret:(0)
GPT part:  0, name:            uboot, start:0x4000, size:0x2000
GPT part:  1, name:            trust, start:0x6000, size:0x2000
GPT part:  2, name:             misc, start:0x8000, size:0x2000
GPT part:  3, name:             dtbo, start:0xa000, size:0x2000
GPT part:  4, name:         resource, start:0xc000, size:0x8000
GPT part:  5, name:           kernel, start:0x14000, size:0x14000
GPT part:  6, name:             boot, start:0x28000, size:0x18000
GPT part:  7, name:           rootfs, start:0x40000, size:0x100000
GPT part:  8, name:         userdata, start:0x140000, size:0x75b4fdf
find part:uboot OK. first_lba:0x4000.
find part:trust OK. first_lba:0x6000.
LoadTrust Addr:0x6000
LoadTrust Addr:0x6400
LoadTrust Addr:0x6800
LoadTrust Addr:0x6c00
LoadTrust Addr:0x7000
LoadTrust Addr:0x7400
LoadTrust Addr:0x7800
LoadTrust Addr:0x7c00
Addr:0x6000 No find trust.img!
LoadTrustBL error:-3
Raw SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit ret = -2, SecureMode = 0
SoftReset, 232100 us

1 Like

Is that log useful? Is there some more work someone needs to do to or information provided to help work out the updates to get the RS2 Plus sorted out?

R2S/R2S Plus are similar but not the same hardware, so getting error when you try to force booting with another firmware is expected.

Probably you should bring these to "For Developers" section, to give devs some idea on this new hardware.