NanoPI R2S is a great OpenWrt device

The root cause of that is due to the Arm processor only supplying numbers instead of names in it's CPU id. The linux kernel won't convert the numbers to names because it doesn't contain conversion tables for all the manner of available cpus.
It should be possible to hardcode into the openwrt build, I guess. I'll hardcode it into the web page on my r2s when I find where that is.

Reference: https://www.cnx-software.com/2018/02/14/human-readable-decoding-of-proc-cpuinfo-for-arm-processors/
There is a package for openwrt called lscpu that does have conversion tables

cpu0 from my nanopi r2s:

root@turtle:~# cat /proc/cpuinfo
processor	: 0
BogoMIPS	: 48.00
Features	: fp asimd evtstrm aes pmull sha1 sha2 crc32 cpuid
CPU implementer	: 0x41
CPU architecture: 8
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4
root@turtle:~# lscpu
Architecture:                    aarch64
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Little Endian
CPU(s):                          4
On-line CPU(s) list:             0-3
Thread(s) per core:              1
Core(s) per socket:              4
Socket(s):                       1
Vendor ID:                       ARM
Model:                           4
Model name:                      Cortex-A53
Stepping:                        r0p4
CPU max MHz:                     1296.0000
CPU min MHz:                     408.0000
BogoMIPS:                        48.00
Vulnerability Itlb multihit:     Not affected
Vulnerability L1tf:              Not affected
Vulnerability Mds:               Not affected
Vulnerability Meltdown:          Not affected
Vulnerability Spec store bypass: Not affected
Vulnerability Spectre v1:        Mitigation; __user pointer sanitization
Vulnerability Spectre v2:        Not affected
Vulnerability Srbds:             Not affected
Vulnerability Tsx async abort:   Not affected
Flags:                           fp asimd evtstrm aes pmull sha1 sha2 crc32 cpuid

Thanks a lot @poddmo for the answer.

Hi, I have noticed a strange thing, if I run R2S with OpenWRT snapshot and I touch or move R2S metal case it reset itself or it power off. If I use alternative firmware like Kelever1988 build based on FriendlyWRT this reset don't happening. Anyone else get this thing?

Thank you very much, greetings zWolf

Here ya go, this will "fix" it:

cp /www/luci-static/resources/view/status/include/10_system.js /www/luci-static/resources/view/status/include/10_system.js.orig
cat /www/luci-static/resources/view/status/include/10_system.js.orig | sed "s/boardinfo\.system/\'Rockchip\ RK3328\ 1.3GHz\ Quad-Core\ Cortex-A53\ \(aarch64\)\'/g" > /www/luci-
static/resources/view/status/include/10_system.js

My overview now looks like this:

1 Like

Hi, with the latest snapshot, I have some problems when I try to load some packages like openvpn-openssl / luci-app-ttyd / luci-app-statistics / wireguard..... . I have errors like missing package o incompatible packages. How can I solve this problem?

Thanks a lot. zWolf

Snapshot is not stable, especially over time.. snapshot target boot images and snapshot packages are rebuilt daily. Even the next day, snapshot packages may no longer be compatible with the previous day's snapshot image. If you need/want to run a snapshot image and install packages at your leisure, you need to mirror the snapshot packages at the time you download the snapshot image. I hope all that is not too confusing :slight_smile:
Check out this post for how I've created my own point-in-time mirror of snapshot:
https://forum.openwrt.org/t/stable-openwrt-version-for-64-bit-arm-raspberry-pi4b/79062/6
I still keep an eye on the change logs, but now it's mostly for security announcements, bugs or features, rather than installation stability.

1 Like

Thanks a lot @poddmo for the answer.

I have download and install latest snapshot (OpenWrt SNAPSHOT r14954-aafbfc6ac3) but I have the same problem with packets

Collected errors:
 * opkg_install_cmd: Cannot install package openvpn-openssl.
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-app-ttyd found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-app-ttyd.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-app-statistics found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-app-statistics.

Cheers zWolf

Hi,
On my NanoPi R2S I my sensors output is not working.
I think I didn't include something when I did compiling, but I don't know what:

root@np0:~# sensors
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
root@np0:~# cat /sys/class/thermal/thermal_zone0/type
soc-thermal
root@np0:~# cat /sys/class/thermal/thermal_zone0/temp
45454
root@np0:~#

Thanks!

Hi! I just received two of these from AliExpress. It took only 16 days for them to arrive so I guess I got lucky. :slightly_smiling_face:

I'm hoping/planning to use these as Wireguard gateways to replace the current OpenVPN link I've got between our home and cottage.

I would greatly appreciate if someone who's had one of these for a longer time could give their opinion if they're reliable enough to survive some months without freezing up or crashing? The load won't be likely be much as the 4G connection at the cottage is around 20-25Mbps.

Ya, they're pretty reliable. Mine is up to 80 days or so without needing a reboot.

2 Likes

what build? snapshot?

It works fine for me as well.

1 Like

I started to experiment with kernel 5.10, that seems it will be the next LTS kernel, it is running well on the R2S, I noticed that it boot faster on 5.10 .

not so good. the ethernet driver is bad, and eat too much cpu time. also, it is so hot that active cooling is necessary.
although it runs at a much higher frequency than ipq40xx(1300MHz vs 717MHz), its actually network performance is just a little better.

Have anyone tried to measure the idle power consumption of the NanoPi R2S?
I saw that xiaobo in #27 mentioned 5W although I think that sounds ridiculous. I have a RockPi S which consumes approx 45mA at 5V USB-C which is 0.2W at idle (Ethernet connected, and measured using the excellent Ruideng UM25C USB meter).
I know the RockPi S is a RK3308 Cortex-A35 and the NanoPI R2S is an RK3328 Cortex-A53 but at idle I would expect them both to be very frugal.
But then again, everyone is reporting high temperatures on the R2S so something must surely be misconfigured in some PMIC driver or something?

I ran some tests on mine today with a UM34C
TL;dr Running iperf3 on both interfaces and stress -c4 draws 3.86W, 0.81A
Idle with WAN and LAN connected draws 1.45W, 0.29A

  • Fresh image on SD
  • connect LAN,WAN
  • Power on and boot
  • log in ssh, luci : install packages, permit iperf3 on wan and lan
  • iperf3 LAN 3minutes (16:47) 940 Mbits/sec
  • iperf3 WAN 3minutes (16:54) 940 Mbits/sec
  • iperf3 LAN & WAN 3minutes (16:58) (WAN:737 Mbits/sec;LAN:571 Mbits/sec)
  • stress -c 4 (17:02)
  • openssl speed (17:07)
  • openssl speed, stress -c2 (17:16)
  • openssl speed, stress -c3 (17:19)
  • openssl speed, stress -c3, iperf3 LAN & WAN (17:21) (WAN:466 Mbits/sec;LAN:601 Mbits/sec)
  • stress -c1 (17:24)
  • idle (17:27)
  • insert usb drive (17:32)
  • bonniexx -d /mnt -u nobody (17:37)
  • stop services, remove wan, lan and usb (17:55)
  • halt (17:59)

5 Likes

That's what I call a detailed measurement session! Very nice work!
Idling at 1.45W is much better than the 5W previously indicated. But isn't kind of odd that it consumes 300mA doing almost nothing?
Anyway, with these number I'm gonna buy one at antratek. Otherwise I would have gone with a PC Engines APU which idles at 6W.

@xiaobo do you have network issues during your reboot issue?

I experience a frequent reboot issue where the R2S becomes unreachable after a reboot. It happens both with FriendlyWRT (20200904) and OpenWRT (snapshots). The issue I see is that after a reboot, either reboot through LuCI menu or reboot command from shell, the R2S is no longer reachable on the LAN interface - I haven't yet confirmed how the WAN behaves during the issue. The issue can be cleared by rebooting a couple of times - it doesn't always clear after the first reboot. The issue can also be cleared by unplugging the ethernet cable from the LAN port for a minute - unplugging and re-plugging the cable quickly doesn't always clear it either.

Once when trying to analyse the problem, I had a ping running to the LAN interface, I noticed that very occasionally some packets got a reply. Upping the ping timeout to 20seconds got replies to most packets in the 7-14 seconds range.

I've started gearing up to analyse the issue further by connecting to the serial debug port and also monitoring the power consumption. When the issue is occurring I can now see that where I thought the R2S had crashed or failed to boot, it is running normally with zero load.
I've also noticed that the power usage is abnormal during the issue. In my post above outlining the various power usage, the issue is occurring during the first 15 minutes on the graph while I'm pinging, plugging and unplugging LAN cable and generally double-checking the networking. The power consumption should have been at the idle level.

This has had a whiff of hardware issue to me due to the issue happening with multiple operating systems. After seeing the impact on the power level, I'm more certain of that. It's like the hardware is not reseting properly. I wonder if it's to do with the USB3 bus for that interface. I'll post more results when I get time for more testing.

Hi, @poddmo
I guess the network problem is probably related to USB3 Bus (LAN), or you try switching wan and LAN, Using the openwrt Master Latest firmware I compiled, I found that the SD card failed to automatically restore boot frequency during reboot.

I noticed a strange thing, the green led on the WAN port (link led) is not always on but blinking. However, the link between router and R2S seems stable. Is this a simple led activation problem or is this a USB 3 to Gigabit driver stability problem?

Immagine

Cheers zWolf