Nano Station M2 loco XW problem

hello friends I can install without problems openwrt in my nano station m2 loco XW


Can you better explain your issue?

sorry i can install openwrt in my Nano Station M2 loco XW

I have a problem like this. I have a nanostation loco m2, firmware XW.v6.3.0.33226.200428.1819, and I'm not able to upload the firmware to the equipment via Web Gui. When I select the bin file and send it to load, I get the message that Firmware image check failed. Error code: 43

I downloaded the new openwrt update (v20.02.0-rc2) to try to make the firmware work with my nanostation loco M2, but I couldn't find the target version for my device's processor (AR7240 MIPS 24KC @400MHz), I compiled the firmware with the ATH79. If I upload this firmware to the device, will it work or will I make it unusable?

If you're running XW stock firmware that means you have the later version called "XW" with AR9342 CPU chip. The non-XW (also known as XM) has AR7241 chip.

Both versions have release ath79 builds in the ath79/generic directory. There is no need to compile.

The factory file will not install over later stock firmware because that firmware requires signed upgrades. A different install method must be used. I prefer to TFTP boot the initramfs then sysupgrade to flash, but this requires a serial connection.

I needed to compile because I'm going to use these mesh devices, so I needed to include libremesh in the firmware. So does it mean that the ATH79 fits my nanostation XW? Will I be able to use this firmware saw Web gui or only via TFTP? If it goes wrong can I recover the original firmware with TFTP?

I tried to install the compiled firmware (v21) on the nanostation loco M2, but I got the message that Wrong Firmware version is uploaded. Please upload the correct version and try again. Could someone help me with any solution that makes an openwrt firmware work on my equipment?

The OpenWrt "factory" files will always be rejected by a new AirOS (> 6.0 or something) because they are not official firmware signed by Ubiquiti. Please quit trying.

It's been a while since I did a new install on one but somewhere in the OpenWrt wiki is a page of "General Procedures for Ubiquiti Devices" which should help.

Thanks for the info, I will try this method. It's not a very trivial method, and it can even be a little tricky. As we work with community networks, our intention was to teach community technicians how to do this procedure, but with this process it will be a little more complicated. But working is what matters, I'll test it and then leave my feedback here.

It only needs to be done once to first install OpenWrt. Once OpenWrt is running on the device, it can be upgraded to new versions from within OpenWrt.

I tried to perform the procedure on my nanostation loco m2 but got the following error. I did the process for both factory and sysupgrade.

root@NIEREMBERG-L5I:/home/nieremberg/lime-packages/openwrt# git clone
Cloning into 'ubnt-bullet-m2hp-openwrt-flashing'...
remote: Enumerating objects: 24, done.
remote: Counting objects: 100% (1/1), done.
remote: Total 24 (delta 0), reused 0 (delta 0), pack-reused 23
Unpacking objects: 100% (24/24), 22.50 KiB | 162.00 KiB/s, done.
root@NIEREMBERG-L5I:/home/nieremberg/lime-packages/openwrt# cd ubnt-bullet-m2hp-openwrt-flashing/
root@NIEREMBERG-L5I:/home/nieremberg/lime-packages/openwrt/ubnt-bullet-m2hp-openwrt-flashing# ls
Makefile  flash-factory.log  flash-sysupgrade.log  restore.log  ubntbox.patched.sha256sum  ubntbox.sha256sum
root@NIEREMBERG-L5I:/home/nieremberg/lime-packages/openwrt/ubnt-bullet-m2hp-openwrt-flashing# make flash-factory FW_OWRT=/path/to/your/openwrt-ath79-generic-ubnt_bullet-m2hp-squashfs-factory.bin
scp ubnt@ ubntbox
The authenticity of host ' (' can't be established.
RSA key fingerprint is SHA256:SnKJhxhFN8c538QGpA7N6jHVHknCvhEMDs4Ilir+t1c.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '' (RSA) to the list of known hosts.
ubnt@'s password:
ubntbox                                                                                                                                                                                                    100%  698KB   1.3MB/s   00:00
ssh-copy-id ubnt@
/usr/bin/ssh-copy-id: ERROR: No identities found
make: *** [Makefile:50: flash-factory] Error 1
root@NIEREMBERG-L5I:/home/nieremberg/lime-packages/openwrt/ubnt-bullet-m2hp-openwrt-flashing# make flash-sysupgrade FW_OWRT=/path/to/your/openwrt-ath79-generic-ubnt_bullet-m2hp-squashfs-sysupgrade.bin
--2021-06-07 14:01:44--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7531809 (7.2M) [application/octet-stream]
Saving to: ‘XW.v6.1.7.32555.180523.1754.bin’

XW.v6.1.7.32555.180523.1754.bin                             100%[========================================================================================================================================>]   7.18M  8.28MB/s    in 0.9s

2021-06-07 14:01:49 (8.28 MB/s) - ‘XW.v6.1.7.32555.180523.1754.bin’ saved [7531809/7531809]

ssh-copy-id ubnt@
/usr/bin/ssh-copy-id: ERROR: No identities found
make: *** [Makefile:60: flash-sysupgrade] Error 1

ssh-copy-id will install your public key on the remote machine for no-password login. In order for it to work you have to have a public key. Run ssh-keygen on your machine to generate the key for it to copy. Use the default location and no passphrase (press enter three times).

I have not used those scripts. Here would be the process to do it manually:

  1. Downgrade the Ubiquiti to 6.1.7 (web gui, ssh, or TFTP recovery)
  2. scp download ubntbox from the running 6.1.7 and patch it. (Only needs to be done once)
  3. scp upload ubntbox and OpenWrt firmware to /tmp on the Ubiquiti
  4. ssh in and use patched ubntbox to flash.

Thanks for the info, but as I'm new to openwrt, I have no idea how I could use these commands. Where can I find a tutorial on how to perform these steps? I've already put the 6.1.7 firmware via TFTP, but now I don't know how to do the remaining steps.

To patch ubntbox do I need to download the device or is the patch done remotely? By the procedure described in the tutorial he talks about remote patching, I was in doubt now. Take a look at this part of the tutorial.

It looks like that process will scp the file out of the router, process it, and leave the resulting file on the PC.

I still can't get openwrt to work on my nanostation loco M2. I didn't know how to execute this last procedure using the scp command. Where could I find a more explanatory tutorial about it?

Of all these steps I was only able to perform the first one. The device has the indicated firmware, but I didn't know how to execute these scp download and scp upload commands, and I also have no idea how I'm going to use patched ubntbox to flash.

When I tried to run the make flash-factory command, I got the message that no identities found, as you can see in the screenshot.