MyBook Live Single - No network

Hello everyone

I have installed OpenWRT on my mybook live (Single) before, and it worked like a dream, today, while trying to install a new disk (after DD the factory image on the disk), this happens (Note: installation as per which worked for me before)

the LED goes, yellow, then green and blue flashing randomly, then green flashing randomly then solid green

At which point, i connected it to my laptop, but i did not get an IP from DHCP, so i configured the laptop to use the static IP

Still, I can not ping, neither can i open that address in the browser

Well, I didn't have the time to research the problem, so i worked around it by flashing the older "21", setting up the network, then flashing the new "22" onto the device, works like a charm, but still a workaround

Not sure if it is relevant, but this is an 8TB seagate SMR drive that is replacing an identical drive that was on the device

I have previously downloaded and re-downloaded and wrote and rewrote the "22" image to the disk, it becomes solid green but with no networking

Hope this helps someone