My ADSL Connection not working after first reboot

Hi

I Have tplink-w8970 running with latest firmware (19.07.4 r11208-ce6496d796)

My ADSL configuration works on fresh installation. But after first reboot, never back again. My config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config atm-bridge 'atm'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'
	option vci '35'
	option vpi '8'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'
	option xfer_mode 'ptm'
	option line_mode 'adsl'
	option firmware '/lib/firmware/lantiq-vrx200-a.bin'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'dsl0.35'
	option proto 'pppoe'
	option username '**********@turk.net'
	option password '*********'
	option type 'bridge'
	option delegate '0'
	option force_link '1'
	option ipv6 '0'
	option keepalive '5 5'
	option mtu '1501'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '***************'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'

System logs on first boot (while adsl is running well):

dsl_status on first boot:

root@OpenWrt:~# service dsl_control status
ATU-C Vendor ID:                          
ATU-C System Vendor ID:                   
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.8.1.8.1.6
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 76829
Errored seconds (ES):                     Near: 0 / Far: 395501
Severely Errored Seconds (SES):           Near: 0 / Far: 53458
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 61
Unavailable Seconds (UAS):                Near: 77292636 / Far: 77292636
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               0.0 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 8.493 Mb/s / Up: 1.215 Mb/s
Line Attenuation (LATN):                  Down: 43.5 dB / Up: 19.1 dB
Signal Attenuation (SATN):                Down: 34.0 dB / Up: 19.1 dB
Noise Margin (SNR):                       Down: 6.2 dB / Up: 6.0 dB
Aggregate Transmit Power (ACTATP):        Down: 11.5 dB / Up: 14.3 dB
Max. Attainable Data Rate (ATTNDR):       Down: 8.578 Mb/s / Up: 1.215 Mb/s
Line Uptime Seconds:                      11
Line Uptime:                              11s

System logs on second boot:

and entering to loop:

dsl_status on second boot:

ATU-C Vendor ID:                          
ATU-C System Vendor ID:                   
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.8.1.8.1.6
API Version:                              4.17.18.6
XTSE Capabilities:                        , , , , , , , 
Annex:                                    
Line Mode:                                
Profile:                                  
Line State:                               DOWN [0x1: exception]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 51523592 / Far: 51523591
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L3 - No power
Latency [Interleave Delay]:               0.0 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 0 b/s / Up: 0 b/s
Line Attenuation (LATN):                  Down: 0.0 dB / Up: 0.0 dB
Signal Attenuation (SATN):                Down: 0.0 dB / Up: 0.0 dB
Noise Margin (SNR):                       Down: 0.0 dB / Up: 0.0 dB
Aggregate Transmit Power (ACTATP):        Down: 0.0 dB / Up: 0.0 dB
Max. Attainable Data Rate (ATTNDR):       Down: 0 b/s / Up: 0 b/s
Line Uptime Seconds:                      0
Line Uptime:                              down

Any suggestions?

Correction, I failed to notice you actually have a VDSL connection. Not ADSL ! I have deleted my previous reply.

Line Mode:                                G.993.2 (VDSL2)
Profile:                                  17a

See Turknet VDSL config posted in owrt wiki page:
https://openwrt.org/docs/guide-user/network/wan/isp-configurations

Compared to your original config file. For VDSL, use:

config dsl 'dsl'
	option line_mode 'vdsl'  # Correcting or removing this line may solve your reboot issue.
config interface 'wan'

	option type 'bridge'   # this line may be invalid too.  I could be wrong.

	option mtu '1492'   # value of 1501 is not supported

dsl_status shows wrong info. My line is doesnt support VDSL annex B. I can connect only with Annex A and ADSL2+

Thinking about it. The TD-W8970 is an ADSL modem router (TD-W9970 VDSL modem router)

I presume it is hardware version v1?

Try the suggested ADSL settings for Turknet I posted in the owrt wikipage.

ie. change the xfer_mode to 'atm' because ADSL does not use 'ptm'. Also probably have to change the interface name to 'dsl0' in WAN interface section.

You may want to test older 19.07 release or 18.06 as you may have found a bug if it is incorrectly reporting VDSL connection.

My hardware version 1.2.

I changed:
xfer_mode 'ptm' to 'atm'
mtu '1492' and ifname 'dsl0' problem solved.
Thanks for suggestion!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.