MWAN3 working on snaphot?

hi i have been using MWAN3 for some time on a HH5 and am looking to move to potentially a RPI4 which unfortunately is only available in snapshot or community build. I have tried a couple of recent snapshots ( this week) and 2 community builds based on 19.073 but all exhibit broken MWAN3 to one degree or the other. Does anyone know of a particular build that would work? I did note on the MWAN openwrt page a warning about snapshots being buggy, so seems to be a "known" feature .. tks in advance

1 Like

yes. The 5.4.x kernel changes some things with how routes are handled internally that breaks mwan3track. This will be fixed before the official 20.x release.

Builds that use the 4.x kernel should still work.

thanks for the reply and this is what i guessed. RPI4 does not have a build on 4.x that i can find after a few days of searching so will look for an alternative solution to MWAN for the moment.

If you don't need a precompiled solution, you can use the SDK to build the 2.10.0 beta version from here, which works on the 5.4.x kernels:

1 Like
  • downloaded the sdk...
  • downloaded the patch...
  • git apply fails
  • cd package/ > git apply fails
  • cd feeds/ > git apply fails

how do 'normal' people use the sdk to compile the package with a patch...? have you written (or can you reference) any instructions on how to do so?

This will be out before 20.x is released so normal users should be able to get it with the 20.x release.

If you want to compile it beforehand:

  1. checkout this branch
  2. add a line to feeds.conf
src-link mwan3_patch <filesystem path to git checkout>
  1. update feeds
  2. install package into the sdk using scripts/feeds install -p mwan3_patch mwan3
  3. compile the package
1 Like

repository is intended to be layered on-top of an OpenWrt buildroot. If you do not have an OpenWrt buildroot installed, see the documentation

i see... so a 'normal' user... needs both a buildroot AND the sdk in order to apply your patch/pr?

If you have build root, you don't need the SDK. Steps are the same.

You can use the SDK if you don't want to build the cross compile environment yourself.

This patch is still in beta though, so it isn't meant for "normal" users at this point. You are welcome to help test it if you would like, though.

1 Like

its already been added to the rpi4 community build so hopefully you'll get some useful feedback... initial testings looking good...

ok... so while it is possible to use the sdk, or buildroot to generate an ipk from either your patch or feed... it is not intended for normal users... gotcha...



The master branch is unstable as it is and this patch hasn't even landed on master yet, so is still experimental.

1 Like

i posted on this to @ [wulfy23] on the community build page- tried the latest snapshot for that build and results mixed for me:

disable MWAN can route down either WAN link
enable MWAN get packet loss 80% on each so that brings tracking up but traffic not so good.
Also LUCI hangs changing MWAN settings
disable MWAN- routing back to "normal"

So i think bit better but still not quite right somewhere

What version of luci-app-mwan3 are you using?

What is your WAN setup?

How are you testing link reliability?

hi see enclosed...
mwan3 2.10.0-1
luci-app-mwan3 git-20.242.66793-0b1dcc8

WAN is 2 x VLAN's eth0.2 and eth0.3 which lead to separate routers plus a tun0 over eth0.2

testing reliability via ping -c 1 -I eth0.2

with MWAN off

root@rpi-dca632c6a3 /39# ping -c 1 -I eth0.2
PING ( 56 data bytes
64 bytes from seq=0 ttl=113 time=39.636 ms

with MWAN on

root@rpi-dca632c6a3 /41# ping -c 10 -I eth0.2
PING ( 56 data bytes
64 bytes from seq=4 ttl=113 time=55.753 ms
64 bytes from seq=5 ttl=113 time=49.410 ms
64 bytes from seq=6 ttl=113 time=44.641 ms
64 bytes from seq=7 ttl=113 time=49.045 ms
64 bytes from seq=8 ttl=113 time=44.004 ms

--- ping statistics ---
10 packets transmitted, 5 packets received, 50% packet loss

i shut down all interfaces for last ping test other than eth0.2 and still drops packets.

turned MWAN back on clean pings 10 from 10

hope that helps

Are any packets dropped with mwan3 turned off and ping -c 50 -I eth0.2

With the 5.4.x kernel, the ping -I <interface> does not work reliably with mwan3 (this is why the 2.10.0 version is needed).

Please use mwan3 wrap wan ping to test. This will force ping to bind to the device associated with wan.

mwan3 wrap can be used with mwan3 turned on or off, but is needed when mwan3 is turned on.

ok cheers for that - you beat me too it as i tried again flattening MWAN config then putting back in- LUCI seems ok now and routing appears to work albeit the ping -I is hit or miss

mwan3 wrap does work ok down both wans..

I will continue to test and see if anything else rattles... cheers

Great! Thank you @anon50098793 for doing the build and thank you @alpynz for testing.

1 Like

just a quick report to say testing seems all ok with this vers- no LUCI hangs after 2 days and routing down 3 wan links works as per expected.