MWAN3 issue - ethernet failover not working

Hi there,

first post here - so hopefully in the right place.

I have tried to get MWAN3 failing over between two ethernet WAN ports (eth0.2 and eth0.3) and I can't get it to work.

My debugging skills have lead me to the hotplugs scripts (/etc/net/15-mwan3) which erroneously identify the interface eth0.3 as eth0.2, which starts the connection tracker.

I dropped debugging lines in the script that calls the connection tracker to export the shell variables so I could see the '$DEVICE' variable.

The network config of the interfaces is correct (), but via the hotplug scripts (I put 'export' in the script and then checked the logs) the '$DEVICE' is incorrect.

I can get it working via manually ifup(ing) the incorrectly identified interface; but if I have any more ifup/ifdown events then it is likely to break.

Where do I look next?


changing 15-MWAN3

case "$ACTION" in

  •     DEVICE="$(uci get network.$INTERFACE.ifname)"

seems to fix my problem; but surely this is a nasty kludge.

Is there a better root cause fix for this?


So Maybe a bit more information will illicit a response:

OpenWRT 18.06.4
Running on a TP-Link AC1750

Question is: why would hot plug scripts say interface 'twan' (configured as 'eth0.3') would be described as DEVICE 'eth0.2' in the environment variables when the hot plug script runs?


Not sure what makes you think this. The forums aren't always the best place to flag up bugs or issues for specific packages.

Latest release was 14 days ago in master, with several open pull requests currently being worked on.

It's a complex package, catering for a wide range of network configurations so certainly, there might be issues with the variable configurations. Best thing to do is report them here: for the attention of the maintainer and contributors.

Rather than bumping an old thread, feel free to create a new one or report any issue you might be having on GitHub.

Don't worry, fixed it.