MWAN Used in Alarm System Backup Connection not connecting on secondary wan (Bosch 3000 with B426M Ethernet)

Hi, I'm back again.

Primary reason for OPENwrt/LEDE project is to provide internet access with backup to my Bosch 3000 Alarm with B426M Ethernet Module. The cable used for my primary internet from street to house is above ground and within reach of a normal adult and hence vulnerable to attach by would-be intruders.

I have a Linksys WRT1900ACv2 Firmware Version LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685). This is connected to my ISP supplied Router (Sagemcom 5355) with the Linksys set to the DMZ zone.

I have MWAN3 installed and configured as per the following link and is set as failover:
My interfaces are "wan" connected through wan port on Linksys and wan2 connected through usb port on Linksys. wan2 is a sierra aircard 320U.

I have OpenVPN installed and configured as per the following link:

I have done testing via my pc connected directly and via VPN to the Linksys and everything appears to operate as it should when I physically remove and reconnect the interfaces. I do IP website check and they change as expected with interface change and I can browse web.

Finally my problem, my alarm system only sends information when connected to primary wan interface.

The alarm has 2 notification systems (both fail to connect on secondary wan2 interface):
SYSTEM1 Email - I use the following settings and port 465. Tried changing email details to my provider email details with no change.
SYSTEM2 Phone App Notification - a cloud ID is provided by the Alarm console and entered into Phone App.

The network that my dongle (AC320U - wan2) connects to uses NAT and I am aware that VPN can not connect through this interface.

Edited Bit
Done a little bit more testing - set up an old d-link Ethernet to wireless bridge I have, put the sim into my phone and set it up as a mobile hotspot --> The alarm worked as it should
Another Test - set up phone as a tethered usb hotspot on the Linksys --> Alarm stopped transmitting.

I have changed some firewall settings (as per previous posts) but have since changed everything back to default settings after vpn and mwan installs.

Any help is much appreciated.

MWAN3 works extremely well with OpenWRT 15.
you can check my notes on how to get it working, I've used those on many places, and some users too:

There is some problems with MWAN3 on LEDE 17 and OpenWRT 18 I think that some were solved on 17.01.5 and I don't know if the 18 were solved or not on the final release 18.06.0

Let us know if it worked for you.

Will have a go in the next couple weeks, thanks for the info.