Multiple problems with the dc502 builds of OpenWrt

Hi, i recently bought a WRT1900ACS, to use it for OpenWrt. I ran stock OpenWrt for the WRT1900ACS for a few months. About a month ago i decided to update the version of OpenWrt i was running, finding out that the device hadn't received an official update for quite a while. This put me behind many updates and kernel versions. I did some research and stumbled upon Davidc502's OpenWrt builds. I reset my router, installed a fresh build of dc502 OpenWRT and was quite happy with it. It had updated drivers, kernels and came with many great packages. However, it only took a few hours for it all to fall apart. The UI became unbearably slow at first. However, i didn't mind as it didn't affect my internet speed of 500/500 MBps fiber. It worked for a couple of weeks until it started capping my internet speed on my desktop to 100/100. I could only get it back to 500/500 by plugging in and out my ethernet cable. But this only lasted for a few hours until i had to do it again. This severely capped my speed and i was confused. I haven't enabled QoS or manually capped my speed. I can't find anyone having a similar problem. I might just consider going back to stock OpenWRT, although it doesn't have the new drivers and kernels, it's still usable and doesn't cap or lag. Also, i can't find out what is slowing things down, as when i do "top" in SSH, it shows 0% on both CPU and VSZ. Any ideas? I can provide any configs or other details if needed.

There is a thread dedicated to those builds you will find tons of information there, and many other users, too.

Alright, i have fixed the UI slowness. It was a uhttpd setting, simply SSH into your OpenWrt router and do this, in order:

uci set uhttpd.main.http_keepalive=0
uci commit
/etc/init.d/uhttpd restart

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.