Multicast not working over bridged AP


I have an Engenius EAP1300 and a MikroTik RouterBOARD wAP G-5HacT2HnD.
Both which I have configured as bridged APs with EAP and dynamic VLANs.

Unicast and broadcast works fine, DHCP works and the stations can reach other services etc.
But multicast doesn't seem to work, so I'm unable for example to get an IPv6 address via SLAAC.
It seems to sometimes work on the mikrotik device

If I run tcpdump on one of the wlan interfaces I can see router advertisements, but the stations doesn't receive them.
I have tried on three different devices, a laptop running linux, an iphone and a ipad, same issue on all.
I have tried to disable multicast_snooping in /sys/class/net/bridgeinterface/bridge/multicast_snooping, but doesn't seem to make any difference.

My wifi configuration is basically the same on both devices, for both radios, only difference is name, radio and nasid

config wifi-iface 'myssid_5'
        option mode 'ap'
        option ssid 'myssid'
        option hidden '1'
        option ieee80211w '1'
        option encryption 'wpa3-mixed'
        option auth_server 'authserver'
        option auth_secret 'mysecret'
        option dynamic_vlan '2'
        option vlan_tagged_interface 'eth0'
        option isolate '1'
        option max_inactivity '1800'
        option device 'radio0'
        option mobility_domain 'f1f1'
        option nasid 'mynasid'
        option pmk_r1_push '1'
        option ieee80211r '1'
        list r0kh '...'
        list r0kh '...'
        list r0kh '...'
        list r0kh '...'
        list r1kh '...'
        list r1kh '...'
        list r1kh '...'
        list r1kh '...'

Does anyone have any idea what the underlying cause might be and how to fix it?