Multi 4G WANs to LAN across openwrt not working

I am not an expert!

I am in a rental house in France that has no fixed line coming in (it is usually a holiday gite). We are here for 18 to 24 months while we rebuild a house destroyed in a fire. The mobile 4G signals are pretty bad but when they work they are OK. Free using Orange is stronger than SFR here.

I have invested in two 4G receivers, one using a Free (it is the name of the company) sim, the other using my usual SFR sim. The Free sim piggy backs the Orange network which is much stronger than my usual supplier SFR at this house.

Both connections can be flaky and both are limited to 200 GB a month and we need about 300 to follow UK internet TV plus all the other things we do.

So after reading up it seemed sensible to try to combine these two 4G inputs through my openwrt router to give a load balanced system that would use both suppliers and spread the load to ensure we had full access to the 400GB without having to switch from one to the other (which is what I have been doing).

So I have the Free router (a private tp-link MR600) feeding its internet into the WAN port of my openwrt router running openwrt 20.02.2 and my SFR 4G router feeding its internet into the LAN4 port of the same router. The Free box is set to and the SFR box is set to The openwrt router runs the LAN and wifi for the house using a network of with the router on

To complicate matters I have a private VPN that the openwrt router accesses using policy based routing but thus far it does not appear to have any impact on what I am trying to do (and I do not think it should).

I tried to use the information in this tutorial:-

to change LAN4 to a second WAN interface called WAN_SFR but could not find the entry for the switch controller.

After reading and searching it says that my version of openwrt uses DSA in lieu of swconfig so I used this information:-

to unlink LAN4 and reset it as a WAN port called WAN_SFR

I have also disabled the original WAN port and generated a new WAN interface called WAN_FREE.

I then followed the tutorial and managed to generate the load balancing interfaces, members, policies and rules but I cannot get it to work properly.

I appear to be using just the new WAN_FREE interface on my internal network. I have disabled the original WAN interface and even removed its static address to make sure it is not being used (but not yet dared to delete it) and I am still accessing the internet over the internal machines. However the RX and TX statistics are still being (identically) shown on both the new WAN_FREE interface and the old, disabled WAN interface and I do not understand why. The WAN_SFR interface is not working at all and the RX and TX remain at 0.

I can ping and (the fixed IP for the WAN_FREE interface) from the openwrt router and from a local LAN machine but I cannot ping or (the fixed IP for the WAN_SFR interface) from anywhere.

When I look at Status:Load Balancing the MWAN Interfaces page shows the original WAN interface in red with a status of offline and the two new interfaces in orange (yellow?) with a status of Disabled with no up or downtime shown.

Using DHCP in lieu of fixed IP on the WAN_SFR port does nothing as the network cannot be found.

The interface is currently set to use device LAN4 but there is also a device called Software VLAN: ”lan4.1” however changing the settings to use this does not appear to make any difference.

I am a bit frustrated as I seem to have got half then system working and cannot work out how to get the second WAN to run. At least the internet is still working!

Can anyone help me solve this? I will post whatever information is needed if you tell me what you need and how I generate it.



tth not familiar with mwan3....
Not to polute your thread too much - why the fixed line isn't an option?
I believe it would have saved you a lot of headaches.

Landlord too mean to put one in! When I signed the contract I did not think as I assumed every house would have a fixed line but apparently it is not so. Installing one is over 900 euros. 4G wifi is much cheaper!

1 Like


I am almost too embarrassed to say I managed to get it working. Apparently the LAN ports are the reverse of the numbering shown in the manual. They are printed on the device as well but in font size 1 as far as I can tell. So it seems I was plugged in to LAN 1 not LAN 4! Quick change over and the interfaces both came up and are working. However some problems remain as the MWAN listing is not showing the interfaces as up (even though they are) and also having finally deleted the WAN interface, the VPN Policies are upset.

I will mark this as solved and open a new thread if needed.

A quick follow up. I was having problems with the MWAN status showing my new WANs as disabled. Also it prevented them from being listed in the OpenVPN policy selection drop down.

I was mystified until I came across a post that said the interfaces should be entered in lower case only. Rather than risk editing the name I simply deleted the interfaces and rebuilt them with lower case names and everything then worked properly. Even though the interface names were entered in lower case, they display in the interface section as upper case however they display correctly in lower case in the MWAN Status listing. All very confusing for a first time user.

See also the post above which is part of the solution!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.